Ticket #930 (closed defect: fixed)

Opened 10 years ago

Last modified 5 weeks ago

kexec fails on the neo; requires existing kexec ATAG patch

Reported by: mwester@… Owned by: laforge@…
Priority: normal Milestone:
Component: kernel Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

The kernel is compiled with kexec enabled, however kexec does not actually
function on the neo. This is a known problem with ARM devices that require
ATAGs to be passed in from the bootloader (as the neo does in order to boot
correctly). A patch is available to resolve this problem (it has been submitted
upstream, accepted, and is expected to be incorporated into 2.6.24).

Attachments

kexec-atags-2.6.22.5.patch (4.7 KB) - added by mwester@… 10 years ago.
Kernel kexec patch to preserve bootloader ATAGs for new kexec'd kernel

Change History

Changed 10 years ago by mwester@…

Kernel kexec patch to preserve bootloader ATAGs for new kexec'd kernel

comment:1 Changed 10 years ago by mwester@…

The 2.6.23 version of this patch can be view here:
http://www.arm.linux.org.uk/developer/patches/viewpatch.php?id=4599/1

comment:2 Changed 10 years ago by laforge@…

  • Status changed from new to assigned

I'm obviously fine with this patch. Will apply once the kernel has stabilized
after the PWM breakage that I introduced a couple of days ago.

comment:3 Changed 10 years ago by laforge@…

  • Status changed from assigned to closed
  • Resolution set to fixed

committed as revision 3169

comment:4 Changed 9 years ago by lindi

[ I don't seem to have permission to reopen this bug, could somebody with sufficient permissions do it? ]

Re #2135 I was investigating different ways to save kernel panic
messages so that they can be retrieved later and thought I should try
kdump which uses kexec only to notice that kexec does not quite work:

With stable-tracking at 1b17c67794364bee I built kexec-tools from the
debian source package 20080324-2 and tried

sudo kexec -l /boot/uImage2.bin --append="`cat /proc/cmdline`"
sudo kexec -e

but got only WSOD. The device also did not show up as usb device or
blink any leds.

My /proc/cmdline contains

rootfstype=jffs2 root=/dev/mtdblock6 console=ttySAC2,115200 console=tty0 loglevel=8 regular_boot mtdparts=physmap-flash:-(nor);neo1973-nand:0x00040000(u-boot),0x00040000(u-boot_env),0x00800000(kernel),0x000a0000(splash),0x00040000(factory),0x0f6a0000(rootfs) rootfstype=ext2 root=/dev/mmcblk0p2 rootdelay=5

in case it matters.

comment:5 Changed 9 years ago by mwester

  • HasPatchForReview unset

kexec requires a zImage; it cannot boot a uImage. The zImage file can be found in the arch/arm/boot directory after the kernel is built. Itis, unfortunately, not packaged in the standard repositories nor present on the standard images. The various distro owners will have to determine how to arrange for the alternate format.

(tested on a gta01 with the current "stable" kernel - boots fine.)

comment:6 Changed 9 years ago by lindi

Thanks a lot! I successfully kexec'ed stable-tracking branch at 80f4b57fef5dcffb on gta02 with boot options

rootfstype=jffs2 root=/dev/mtdblock6 console=ttySAC2,115200 console=tty0 loglevel=8 regular_boot mtdparts=physmap-flash:-(nor);neo1973-nand:0x00040000(u-boot),0x00040000(u-boot_env),0x00800000(kernel),0x000a0000(splash),0x00040000(factory),0x0f6a0000(rootfs) rootfstype=ext2 root=/dev/mmcblk0p2 rootdelay=5 panic=10

comment:7 Changed 5 weeks ago by JustDox

Viagra India Pill <a href=http://cial1.xyz/buy-generic-cialis-online.php>Buy Generic Cialis Online</a> Generique Cialis Viagra Viagra Et Effets Indesirables <a href=http://viag1.xyz/viagra-free-trial.php>Viagra Free Trial</a> Side Effects Of Amoxicillin Trihydrate Foreign Pharmacies <a href=http://kama1.xyz/kamagra-cheap.php>Kamagra Cheap</a> Amoxicillin Generic Cialis Ci Vuole La Ricetta <a href=http://zol1.xyz/zoloft-online.php>Zoloft Online</a> Order Lasix Overnight Delivery Online Dapoxetine <a href=http://kama1.xyz/buy-kamagra-cheap.php>Buy Kamagra Cheap</a> E Ricrescita Propecia Finasteride Amoxicillin Enterobacter <a href=http://zol1.xyz/brand-zoloft-online.php>Brand Zoloft Online</a> Prix Propecia Cialis One Day Terapia <a href=http://cial1.xyz/generic-cialis-100mg.php>Generic Cialis 100mg</a> Comprar Cialis 5 Mg Generico Finasteride 1 Mg No Prescription Needed <a href=http://viag1.xyz/fast-delivery-viagra.php>Fast Delivery Viagra</a> Prix Xenical 120 Mg Cialis Echtheit Prufen <a href=http://viag1.xyz/buy-viagra.php>Buy Viagra</a> Cialis Dolor De Cabeza Malegra 100 Sunrise <a href=http://zol1.xyz/zoloft-generic-name.php>Zoloft Generic Name</a> Cialis O Viagra Cual Comprar Priligy Eu <a href=http://inderal.ccrpdc.com/buy-propranolol-40mg.php>Buy Propranolol 40mg</a> Keflex And Side Effects Buy Accutane Forum <a href=http://lasix.ccrpdc.com/cheap-lasix-tablets.php>Cheap Lasix Tablets</a> Cialis Wirkung Dosis Dutasteride Propecia 1mg <a href=http://kama1.xyz/cheap-kamagra-usa.php>Cheap Kamagra Usa</a> Ward 939 Capsule buy accutane from canada <a href=http://cial5mg.xyz/cheapest-cialis.php>Cheapest Cialis</a> Cialis Generique Test Awc Canadian Pharmacy <a href=http://kamagra.ccrpdc.com/order-cheap-kamagra.php>Order Cheap Kamagra</a> Cephalexin Food Belgium Viagra <a href=http://cial1.xyz/cialis-online-pharmacy.php>Cialis Online Pharmacy</a> Amitriptyline No Rx Baclofen Generique En Canada <a href=http://cial5mg.xyz/cialis-to-buy.php>Cialis To Buy</a> Diflucan Without A Prescription Buy Kamagra India <a href=http://cial1.xyz/map.php>Buying Cialis Online</a> Canadian Drugs Accepting Visa Card Malegra Dxt Plus <a href=http://zol1.xyz/zoloft-50mg.php>Zoloft 50mg</a> Viagra 25 Mg Prix Cialis Without Perscription <a href=http://cial5mg.xyz/cialis-buy.php>Cialis Buy</a> Achat Viagra Quel Site Betaxolol <a href=http://cial5mg.xyz/cialis-20mg-price.php>Cialis 20mg Price</a> Kamagra Oral Jelly Kaufen Deutschland Female Kamagra Tablets <a href=http://cial5mg.xyz/brand-cialis-online.php>Brand Cialis Online</a> Viagra Originale On Line Viagra Venta Precio <a href=http://cial1.xyz>Buy Cialis</a> Amoxil Categorie De Grossesse Overnight Secure Dutasteride Medicine With Free Shipping <a href=http://priligy.ccrpdc.com/online-priligy.php>Online Priligy</a> Viagra Professional 100mg Pills Amoxicillin 875 Mg Looks Like <a href=http://levitra.ccrpdc.com/levitra-best-prices.php>Levitra Best Prices</a> About Tadalis Sx Cialis 5 Mg Precio En Colombia <a href=http://zol1.xyz/ordina-zoloft-online.php>Ordina Zoloft Online</a> Buy Nolvadex Uk M <a href=http://kama1.xyz/purchase-cheap-kamagra.php>Purchase Cheap Kamagra</a> Buy Zithromax Online Cheap Cialis Quante Ore Prima <a href=http://cial1.xyz/brand-cialis-online.php>Brand Cialis Online</a> I Want To Buy Alli! Viagra Egitto <a href=http://cial1.xyz/cialis-online-cs.php>Cialis Online Cs</a> Levitra On Line Sale Dosis Cialis 10 Mg <a href=http://viag1.xyz/generic-viagra-pills.php>Generic Viagra Pills</a> Silagra 100 Viagra Italiano <a href=http://kama1.xyz/kamagra-jellies.php>Kamagra Jellies</a> Viagra Y Sertralina Cialis Moins Cher Paris <a href=http://viag1.xyz/fast-delivery-viagra.php>Fast Delivery Viagra</a> Levaquin Medicine For Sale Shipped Ups Cialis Precio Farmacia Espana <a href=http://cial1.xyz/fast-delivery-cialis.php>Fast Delivery Cialis</a> Dapoxetina Ssri About Zithromax <a href=http://cial5mg.xyz/cialis-free-trial.php>Cialis Free Trial</a> Cephalexin To Treat Bronchitis Priligy Es Eficaz <a href=http://kama1.xyz/cost-of-kamagra.php>Cost Of Kamagra</a> Baclofene Cigarette Propecia Provoca Esterilidad <a href=http://viag1.xyz/order-cheap-viagra.php>Order Cheap Viagra</a> Buy Cialis 20mg Europe Cephalexin 500 Mg Dosages Tev <a href=http://kama1.xyz/kamagra-gel-online.php>Kamagra Gel Online</a> Priligy Comprimes Cialis 20 Mg 27 <a href=http://zol1.xyz/purchase-cheap-zoloft.php>Purchase Cheap Zoloft</a> Canadian Pharmacy 24 Where To Buy On Line Elocon Without Rx <a href=http://viag1.xyz/buying-viagra-online.php>Buying Viagra Online</a> Generique Kamagra France Propecia Side Effects Reviews <a href=http://cial5mg.xyz/cialis-price.php>Cialis Price</a> Propecia 0 5 Viagrawithout A Prescription <a href=http://cial1.xyz/cialis-online-no.php>Cialis Online No</a> Propecia Work Vilitra <a href=http://viag1.xyz/order-cheap-viagra.php>Order Cheap Viagra</a> Correct Dosage Amoxicillin Cat Priligy France <a href=http://cial5mg.xyz/cialis-online-cs.php>Cialis Online Cs</a> Canada Pharmacy Online Alli Diet Pill Isotretinoin Isotrex <a href=http://viag1.xyz/purchase-viagra-cheap.php>Purchase Viagra Cheap</a> Hydrochlorothiazide Aldoril Secure Medicine Ondansetron <a href=http://kama1.xyz/buy-generic-kamagra-online.php>Buy Generic Kamagra Online</a> Geniune Accutane Is There Penicillen In Keflex <a href=http://zol1.xyz/online-zoloft.php>Online Zoloft</a> Cialis Generika Indien

Note: See TracTickets for help on using tickets.