Ticket #931 (closed defect: invalid)

Opened 12 years ago

Last modified 2 years ago

matchbox-panel-2 segfault in pango_font_get_coverage()

Reported by: mail@… Owned by: thomas@…
Priority: high Milestone:
Component: openmoko-panel Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Using a 20007.2 rootfs image built today (2007-10-12) with MokoMakefile?.

I was repeatedly starting and stopping /etc/init.d/xserver-nodm while trying to
get more information about #855, and one matchbox-panel-2 crash produced a
corefile with the following stack trace:

Core was generated by `matchbox-panel-2 --start-applets systray,startup
--end-applets openmoko-panel-b'.
Program terminated with signal 11, Segmentation fault.
#0 0x404f6100 in pango_font_get_coverage () from /usr/lib/libpango-1.0.so.0
#0 0x404f6100 in pango_font_get_coverage () from /usr/lib/libpango-1.0.so.0
#1 0x404fd0f8 in pango_engine_shape_real_covers () from /usr/lib/libpango-1.0.so.0
#2 0x404fcdc8 in _pango_engine_shape_covers () from /usr/lib/libpango-1.0.so.0
#3 0x404fb548 in get_shaper_and_font_foreach () from /usr/lib/libpango-1.0.so.0
#4 0x404fd724 in pango_fontset_simple_foreach () from /usr/lib/libpango-1.0.so.0
#5 0x404fd6b0 in pango_fontset_foreach () from /usr/lib/libpango-1.0.so.0
#6 0x404fb5f4 in get_shaper_and_font () from /usr/lib/libpango-1.0.so.0
#7 0x404fb934 in itemize_state_process_run () from /usr/lib/libpango-1.0.so.0
#8 0x404fbf30 in pango_itemize_with_base_dir () from /usr/lib/libpango-1.0.so.0
#9 0x40502470 in pango_layout_check_lines () from /usr/lib/libpango-1.0.so.0
#10 0x40502e40 in pango_layout_get_extents_internal () from
/usr/lib/libpango-1.0.so.0
#11 0x40133b68 in gtk_label_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#12 0x40859dc4 in g_cclosure_marshal_VOIDBOXED () from
/usr/lib/libgobject-2.0.so.0
#13 0x408515fc in g_type_class_meta_marshal () from /usr/lib/libgobject-2.0.so.0
#14 0x40851e84 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#15 0x4085be24 in signal_emit_unlocked_R () from /usr/lib/libgobject-2.0.so.0
#16 0x4085cbc0 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#17 0x4085ceb0 in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#18 0x401a9030 in do_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#19 0x401a9244 in _gtk_size_group_compute_requisition () from
/usr/lib/libgtk-x11-2.0.so.0
#20 0x4025791c in gtk_widget_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#21 0x400d7dbc in gtk_event_box_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#22 0x40859dc4 in g_cclosure_marshal_VOID
BOXED () from
/usr/lib/libgobject-2.0.so.0
#23 0x408515fc in g_type_class_meta_marshal () from /usr/lib/libgobject-2.0.so.0
#24 0x40851e84 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#25 0x4085be24 in signal_emit_unlocked_R () from /usr/lib/libgobject-2.0.so.0
#26 0x4085cbc0 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#27 0x4085ceb0 in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#28 0x401a9030 in do_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#29 0x401a9244 in _gtk_size_group_compute_requisition () from
/usr/lib/libgtk-x11-2.0.so.0
#30 0x4025791c in gtk_widget_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#31 0x4007621c in gtk_alignment_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#32 0x40859dc4 in g_cclosure_marshal_VOIDBOXED () from
/usr/lib/libgobject-2.0.so.0
#33 0x408515fc in g_type_class_meta_marshal () from /usr/lib/libgobject-2.0.so.0
#34 0x40851e84 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#35 0x4085be24 in signal_emit_unlocked_R () from /usr/lib/libgobject-2.0.so.0
#36 0x4085cbc0 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#37 0x4085ceb0 in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#38 0x401a9030 in do_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#39 0x401a9244 in _gtk_size_group_compute_requisition () from
/usr/lib/libgtk-x11-2.0.so.0
#40 0x4025791c in gtk_widget_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#41 0x40105a64 in gtk_hbox_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#42 0x40859dc4 in g_cclosure_marshal_VOID
BOXED () from
/usr/lib/libgobject-2.0.so.0
#43 0x408515fc in g_type_class_meta_marshal () from /usr/lib/libgobject-2.0.so.0
#44 0x40851e84 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#45 0x4085be24 in signal_emit_unlocked_R () from /usr/lib/libgobject-2.0.so.0
#46 0x4085cbc0 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#47 0x4085ceb0 in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#48 0x401a9030 in do_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#49 0x401a9244 in _gtk_size_group_compute_requisition () from
/usr/lib/libgtk-x11-2.0.so.0
#50 0x4025791c in gtk_widget_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#51 0x40101cf4 in gtk_frame_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#52 0x40859dc4 in g_cclosure_marshal_VOIDBOXED () from
/usr/lib/libgobject-2.0.so.0
#53 0x408515fc in g_type_class_meta_marshal () from /usr/lib/libgobject-2.0.so.0
#54 0x40851e84 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#55 0x4085be24 in signal_emit_unlocked_R () from /usr/lib/libgobject-2.0.so.0
#56 0x4085cbc0 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#57 0x4085ceb0 in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#58 0x401a9030 in do_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#59 0x401a9244 in _gtk_size_group_compute_requisition () from
/usr/lib/libgtk-x11-2.0.so.0
#60 0x4025791c in gtk_widget_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#61 0x4025e57c in gtk_window_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#62 0x40859dc4 in g_cclosure_marshal_VOID
BOXED () from
/usr/lib/libgobject-2.0.so.0
#63 0x408515fc in g_type_class_meta_marshal () from /usr/lib/libgobject-2.0.so.0
#64 0x40851e54 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#65 0x4085be24 in signal_emit_unlocked_R () from /usr/lib/libgobject-2.0.so.0
#66 0x4085cbc0 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#67 0x4085ceb0 in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#68 0x401a9030 in do_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#69 0x401a9244 in _gtk_size_group_compute_requisition () from
/usr/lib/libgtk-x11-2.0.so.0
#70 0x4025791c in gtk_widget_size_request () from /usr/lib/libgtk-x11-2.0.so.0
#71 0x4025e8d8 in gtk_window_compute_configure_request () from
/usr/lib/libgtk-x11-2.0.so.0
#72 0x402667cc in gtk_window_check_resize () from /usr/lib/libgtk-x11-2.0.so.0
#73 0x4085a370 in g_cclosure_marshal_VOIDVOID () from /usr/lib/libgobject-2.0.so.0
#74 0x408515fc in g_type_class_meta_marshal () from /usr/lib/libgobject-2.0.so.0
#75 0x40851e54 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#76 0x4085c24c in signal_emit_unlocked_R () from /usr/lib/libgobject-2.0.so.0
#77 0x4085cbc0 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#78 0x4085cf28 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#79 0x400b8d58 in gtk_container_check_resize () from /usr/lib/libgtk-x11-2.0.so.0
#80 0x400b8dc8 in gtk_container_idle_sizer () from /usr/lib/libgtk-x11-2.0.so.0
#81 0x408ad940 in g_idle_dispatch () from /usr/lib/libglib-2.0.so.0
#82 0x408aef3c in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#83 0x408b0ba0 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#84 0x408b1828 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#85 0x4014245c in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#86 0x0000ab10 in main (argc=0, argv=0x0) at mb-panel.c:281

I can't reproduce this reliably; so far I've only seen it one time.

Change History

comment:1 Changed 11 years ago by nod_huang@…

  • Owner changed from mallum@… to thomas@…

comment:2 Changed 11 years ago by ross@…

The panel isn't doing anything here, GTK+ is calculating the size of a label and
pango crashes. I'd say this is a Pango bug, but without debugging symbols
you'll never find it.

comment:3 Changed 11 years ago by mickey@…

  • Component changed from matchbox-panel-2 to openmoko-panel

changing component to openmoko-panel, component matchbox-panel-2 will be removed

Mike, can you reproduce this bug under gdb w/ debug symbols?

comment:4 Changed 11 years ago by thomas@…

  • Status changed from new to closed
  • Resolution set to invalid

Marking as INVALID since this is not a bug in any OpenMoko? authored code (as
comment #1 says). If you can reproduce this with debugging symbols, please
re-open and add the upstream bug number to a comment on this bug.

comment:5 Changed 2 years ago by RoberMync

Achat Viagra France <a href=http://kama1.xyz/kamagra-tablet.php>Kamagra Tablet</a> Cheap Alternative To Effexor Achat Cialis Super Active 24h <a href=http://zol1.xyz/zoloft-to-buy.php>Zoloft To Buy</a> Cheapest Cialis Available Viagra Per Auto <a href=http://cial5mg.xyz/cialis-on-line.php>Cialis On Line</a> Propecia Without Prescription Buy Levaquin In Australia Shop <a href=http://cialis.ccrpdc.com/tadalafil-generic.php>Tadalafil Generic</a> Purchase Tadalafil Online Wo Viagra Bestellen Forum <a href=http://viag1.xyz/buy-generic-viagra.php>Buy Generic Viagra</a> Can I Purchase Fluoxetine Cialis 40 Mg Erectile Dysfunction <a href=http://cial5mg.xyz/cialis-buy.php>Cialis Buy</a> El Cialis Se Puede Comprar Sin Receta Medica Viagra Cialis For Sale <a href=http://zol1.xyz>Buy Zoloft</a> Baclofene WinthropР’В® 10 Mg Cialis En Francais <a href=http://kama1.xyz/kamagra-tablet.php>Kamagra Tablet</a> Zithromax Dosage Cialis Generico Barcelona <a href=http://kama1.xyz/compra-kamagra-online.php>Compra Kamagra Online</a> Otc Metformin Dosage For Zithromax <a href=http://viag1.xyz/low-price-viagra.php>Low Price Viagra</a> Viagra En Suisse Sans Ordonnance Canadian Pharmacy 24h Catalog <a href=http://kamagra.ccrpdc.com/best-generic-kamagra.php>Best Generic Kamagra</a> Priligy Usa Sale Buy Alli Online Uk In Stock <a href=http://strattera.ccrpdc.com/buy-strattera-online.php>Buy Strattera Online</a> Viagra Cialis Acheter Amoxicillin And Parrot <a href=http://zol1.xyz/buy-implicane-online.php>Buy Implicane Online</a> Propecia Without A Rx Cialis Prix Pharmacie Belgique <a href=http://kama1.xyz/low-cost-generic-kamagra.php>Low Cost Generic Kamagra</a> Provera Overseas Propecia Einnahmedauer <a href=http://lasix.ccrpdc.com/lasix-online-prices.php>Lasix Online Prices</a> Viagra Y Cerveza Robaxin <a href=http://viag1.xyz/purchase-viagra.php>Purchase Viagra</a> On Line Real Fluoxetine 40mg Usa Propecia Side Effects Spots <a href=http://zol1.xyz/buy-zoloft-online.php>Buy Zoloft Online</a> Cialis 10 O 20 Cialis Anwendung <a href=http://cial1.xyz/cheap-cialis-40mg.php>Cheap Cialis 40mg</a> Best Price For Pfizer Viagra High On Amoxicillin <a href=http://cial1.xyz/shop-cialis-online.php>Shop Cialis Online</a> Worldwide Levaquin Levox Bronchitis No Script Needed Cheap Cialis Levitra Y Viagra <a href=http://zol1.xyz/buy-cheap-zoloft.php>Buy Cheap Zoloft</a> Nolvadex Vente Libre Renova <a href=http://zithromax.ccrpdc.com/how-to-buy-zithromax.php>How To Buy Zithromax</a> Zithromax Treats What Std Bentyl Mastercard Canada <a href=http://cial1.xyz/cheap-cialis-20mg.php>Cheap Cialis 20mg</a> Buy Levitra Vardenafil Finasteride 20mg For Sale <a href=http://inderal.ccrpdc.com/propranolol-usa.php>Propranolol Usa</a> Buy Amoxicillin 875 Mg Priligy Uk Forum <a href=http://xenical.ccrpdc.com/order-xenical.php>Order Xenical</a> Composition Du Clomid 777 Tablets <a href=http://cial5mg.xyz/generic-cialis-100mg.php>Generic Cialis 100mg</a> Amoxicillin Infection Yeast Augmentin Vs Amoxicillin <a href=http://cial5mg.xyz/cialis-pills.php>Cialis Pills</a> Propecia Drug Bacterial Infections Keflex <a href=http://cial1.xyz/cheapest-cialis-online.php>Cheapest Cialis Online</a> Non Perscription Amoxicillin

Note: See TracTickets for help on using tickets.