Ticket #941 (closed defect: worksforme)

Opened 10 years ago

Last modified 9 years ago

Kinetic scrolling is hard to use with fingers

Reported by: igorfoox@… Owned by: mickey
Priority: high Milestone:
Component: openmoko-libs Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

When using fingers to scroll it's really easy to get the touch part of the
touch-and-drag recognized as a click. This is a bit better when using the
stylus, but I'm sure that finger scroll is also a use case.

I'm not entirely sure what can be done to make this better. One possibility is
to make the UI use a double-click instead of a single-click for activating items
as it currently does. Then a single-click recognized as part of a scroll won't
be confused with the activating click.

If this is in the wrong component please redirect, I wasn't sure where to file this.

Change History

comment:1 Changed 10 years ago by alphaone@…

In my experience this comes from your finger "bouncing", i.e. you put your
finger on the touch screen and tslib registers a press but right after that your
pressure releases and tslib thinks that you in fact have just clicked on the
touch screen.
With a stylus it would be less likely to happen since the pressure there is larger.
Using double clicks on a touch screen is quite cumbersome and in our GUI style
guidelines the double click is "strongly discouraged" (see
http://wiki.openmoko.org/wiki/GUI_Style_Guidelines#Touch_Screen).
We would need some kind of pressure detection/hysteresis for the touch screen,
but I'm not quite sure if/how we can do this.

comment:2 Changed 10 years ago by alphaone@…

I just started ts_test and had a look at the debug output when I make the
typical "scroll gesture".

If I don't press hard enough right at the beginning this is what I get:
1192555459.363945: 203 191 1
1192555459.378897: 203 191 0
1192555459.413949: 224 357 1
1192555459.428926: 202 268 1
1192555459.443950: 190 276 1
1192555459.458950: 180 294 1
1192555459.473949: 178 308 1
1192555459.488945: 173 336 1
1192555459.488945: 172 356 1
1192555459.518898: 185 406 0

So it first registers a click and then a drag. For the time being this situation
can be avoided by pressing harder.

comment:3 Changed 9 years ago by thomas@…

There have been several improvements to the code for this. Is the click problem
still and issue?

comment:4 Changed 9 years ago by mickey@…

  • Component changed from neod to openmoko-libs

Fixing component.

comment:5 Changed 9 years ago by roh

  • Owner changed from mickey@… to mickeyl

comment:6 Changed 9 years ago by roh

  • Owner changed from mickeyl to mickey

comment:7 Changed 9 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to worksforme

2007.2 and the kinetic scrolling should be quite okay now.

Note: See TracTickets for help on using tickets.