Ticket #957 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

No driver for HDQ bus / coulomb counter in new GTA02 battery

Reported by: laforge@… Owned by: willie_chen@…
Priority: high Milestone:
Component: kernel Version: current svn head
Severity: normal Keywords:
Cc: buglog@…, sven-openmoko@…, willie_chen@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

The new battery contains a coulomb counter for accurate charge state reading at
any given time. The digital interface is HDQ, connected to an open-drain GPIO
of the PCF50633 PMU. We need a bit-banging HDQ controller driver for the
PCF50633 and a device driver for the actual coulomb counter circuit.

Change History

comment:1 Changed 11 years ago by willie_chen@…

  • Owner changed from laforge@… to michael@…

comment:2 Changed 11 years ago by willie_chen@…

  • Cc willie_chen@… added

comment:3 Changed 11 years ago by willie_chen@…

I tried to implement HDQ protocol in device driver. When I controlled the GPIO3
on PMU, It need to be controlled by i2c. But responding time is too long to
implement HDQ protocol.

We will re-design hardware version GTA02A5. HDQ protocol is controlled by two
GPIOs. That will decrease response time while using i2c.

comment:4 Changed 11 years ago by willie_chen@…

  • Owner changed from michael@… to willie_chen@…

comment:5 Changed 11 years ago by andy@…

  • Status changed from new to assigned
  • blocked set to 341

Sounds like validation of the HDQ action effectively blocks release since it
involves a new hardware spin. Adding as blocker for BZ341/release.

comment:6 Changed 11 years ago by sven-openmoko@…

  • Cc sven-openmoko@… added

comment:7 Changed 11 years ago by andy

  • Status changed from assigned to closed
  • Resolution set to fixed

I solved this using FIQ / HDQ / BQ27000 driver structure months ago, closing as fixed.

Note: See TracTickets for help on using tickets.