Ticket #967 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

openmoko-today clock doesn't honour timezone DST

Reported by: koen@… Owned by: chris@…
Priority: high Milestone:
Component: openmoko-today Version: current svn head
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

See attached screenshot for the problem: mb-panel clock gets the time right
(20:29), but the jana clock doesn't (19:29)

Attachments

190372708cb30ae67fa7d703efaa5968.png (38.6 KB) - added by koen@… 11 years ago.
screenshot showing the time problem

Change History

Changed 11 years ago by koen@…

screenshot showing the time problem

comment:1 Changed 11 years ago by koen@…

root@a780:/etc/gtk-2.0# ipkg list_installed | grep jana ; ipkg list_installed |
grep today
libjana-ecal0 - 0.1.0+svnr665-r4 - O-Hand Jana Library
libjana-gtk0 - 0.1.0+svnr665-r4 - O-Hand Jana Library
libjana0 - 0.1.0+svnr665-r4 - O-Hand Jana Library
openmoko-today2 - 0.1.0+svnr3287-r2 - The OpenMoko? Application Launcher

comment:2 Changed 11 years ago by thomas@…

  • Owner changed from thomas@… to chris@…

comment:3 Changed 11 years ago by koen@…

I just realized that if DST would be the problem jana would have said '21:29',
not '19:39', so it is merely a timezone problem.

comment:4 Changed 11 years ago by chris@…

Where is the timezone set, so I can add it to the timezone detection function?
libjana respects DST and timezones on the desktop, either through the Evolution
timezone key, through the debian timezone file or the SuSE/Redhat timezone
configuration files, or finally through libc.

comment:5 Changed 11 years ago by koen@…

the timezone is set by making a symlink from
/usr/share/zoneinfo/<continent>/<city> to /etc/localtime.

I suspect jana is missing a tzset() or localtime(), since the matchbox clock and
'date' are picking it up correctly.

comment:6 Changed 11 years ago by chris@…

That isn't how jana gets the time unfortunately, but I'll add a check for
/etc/localtime too tomorrow, that should fix this - I assume that /etc/timezone
isn't there?

comment:7 Changed 11 years ago by chris@…

This should be fixed in r666 (oooh..):

  • libjana-ecal/jana-ecal-utils.c: (jana_ecal_utils_guess_location): Check /etc/localtime symlink if it exists; also verify that whatever timezone returned has a matching built-in ecal timezone

koen, could you verify that this is fixed for you? If it isn't, what timezone do
you have set? I'll investigate further if necessary.

comment:8 Changed 11 years ago by koen@…

before I test:

root@fic-gta01:/etc$ ls -la /etc/localtime /etc/time*
lrwxrwxrwx 1 root root 36 Oct 3 11:48 /etc/localtime ->
/usr/share/zoneinfo/Europe/Amsterdam
-rw-r--r-- 1 root root 13 Oct 28 11:40 /etc/timestamp

root@fic-gta01:/etc$ ipkg list_installed | grep tzda
tzdata - 2007e-r0 - Timezone data
tzdata-europe - 2007e-r0 - Timezone data

comment:9 Changed 11 years ago by koen@…

  • Status changed from new to closed
  • Resolution set to fixed

comment:10 Changed 11 years ago by dos

I have correct timezone setted (Europe/Warsaw? - pidgin, matchbox clock, date command and many others shows good time), but openmoko-today always shows me -1 hour (now it's 16:22, but om-today shows 15:22)

root@om-gta02:~# opkg list_installed | grep tzdata
tzdata - 2007k-r3.01 -
tzdata-africa - 2007k-r3.01 -
tzdata-americas - 2007k-r3.01 -
tzdata-antarctica - 2007k-r3.01 -
tzdata-arctic - 2007k-r3.01 -
tzdata-asia - 2007k-r3.01 -
tzdata-atlantic - 2007k-r3.01 -
tzdata-australia - 2007k-r3.01 -
tzdata-europe - 2007k-r3.01 -
tzdata-pacific - 2007k-r3.01 -
root@om-gta02:~# opkg list_installed | grep openmoko-today
openmoko-today2 - 0.1.0+svnr4168-r2 -
openmoko-today2-folders - 0.1.0+svnr3704-r3 -
root@om-gta02:~#

(i wanted to reopen, but i don't have permissions)

comment:11 Changed 11 years ago by dos

Oh, i forgot:
root@om-gta02:~# opkg list_installed | grep jana
libjana-ecal0 - 0.1.0+svnr728-r5 -
libjana-gtk0 - 0.1.0+svnr728-r5 -
libjana0 - 0.1.0+svnr728-r5 -
root@om-gta02:~#

Note: See TracTickets for help on using tickets.