Ticket #98 (closed enhancement: fixed)

Opened 12 years ago

Last modified 11 years ago

how to do touch panel calibration in factory and store value in flash

Reported by: laforge@… Owned by: mickey@…
Priority: high Milestone:
Component: neod Version: current svn head
Severity: minor Keywords:
Cc: buglog@…, meriac@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description


Change History

comment:1 Changed 12 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to wontfix

Until now, the touchscreens have shown a really low mass production variance.
We're shipping precomputed calibration constants with OM-2007.2 and I didn't
hear any complaints about that. Closing as WONTFIX for now.

comment:2 Changed 12 years ago by laforge@…

  • Cc meriac@… added
  • Status changed from closed to reopened
  • Resolution wontfix deleted

this is just because all the panels are from one batch at the moment. that will
definitely change in the future, and actually even half of the
currently-being-produced units might have a different batch.

Milosch's new GTA02 production process / flow will however have provision for
touchscreen calibration. The question is still how and where to store. Since
the testing software is intended to run from within a linux system, it's
probably possible to even write it into the rootfs.

comment:3 Changed 11 years ago by mickey@…

  • Status changed from reopened to closed
  • Resolution set to fixed

The next batch of display showed no more variations. Closing this again until we
actually have a problem with calibration.

Note: See TracTickets for help on using tickets.