Ticket #980 (closed defect: invalid)

Opened 11 years ago

Last modified 11 years ago

ipkg lists are stored in flash

Reported by: hrw@… Owned by: mickey@…
Priority: lowest Milestone:
Component: Applications & Dependencies Version: current svn head
Severity: trivial Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

"ipkg update" store packages lists in /var/lib/ipkg/ directory. But it is not
longer in tmpfs but in rootfs so it takes precious space now.

/var/volatile/cache/ipkg/ would be much better place

Change History

comment:1 Changed 11 years ago by mickey@…

Is this OpenMoko?-specific? What do other distributions do?

comment:2 Changed 11 years ago by hrw@…

It was changed a bit of time ago in OE so other distros also has that problem.
In Poky we do not merged that yet. So maybe it is also OE bug.

comment:3 in reply to: ↑ description Changed 11 years ago by raster

  • Priority changed from high to lowest
  • Severity changed from blocker to trivial

Replying to hrw@openedhand.com:

"ipkg update" store packages lists in /var/lib/ipkg/ directory. But it is not
longer in tmpfs but in rootfs so it takes precious space now.

/var/volatile/cache/ipkg/ would be much better place

So the alternative is store in tmpfs and thus consume precious RAM instead of flash. either way you lose something. it's simply a policy change to have it on flash instead of RAM. i don't see this as something that belongs as a defect, task or enhancement in this tracker. it's a discussion to be had on a mailing list about a personal system preference. made trivial/lowest priority to reflect this. should we close it as invalid?

comment:4 Changed 11 years ago by raster

  • Status changed from new to closed
  • Resolution set to invalid

actually - should close as this is not a bug or enhancement. it's a personal preference of where you want to consume resources. oe as moved to consuming flash, not ram.

Note: See TracTickets for help on using tickets.