Ticket #990 (closed defect: worksforme)

Opened 11 years ago

Last modified 11 years ago

Missing libxod.tar.gz while building openmoko from scratch

Reported by: rishi_date@… Owned by: mickey@…
Priority: high Milestone:
Component: Autobuilds / Snapshots Version: 2007.2
Severity: critical Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

I have followed the instructions mentioned on Openmoko Wiki "Building OpenMoko?
from Scratch".
After giving the instruction "bitbake openmoko-devel-image", we are getting the
following error.


NOTE: Running task 773 of 2696 (ID: 2363,
/home/moko/oe/packages/libxosd/libxosd_svn.bb, do_fetch)
NOTE: package libxosd-2.2.15+svn20071105: started
NOTE: package libxosd-2.2.15+svn20071105-r4: task do_fetch: started
NOTE: fetch
http://downloads.openmoko.org/sources/current_libxosd.svn.sourceforge.net_.svnroot.libxosd.source__20071105.tar.gz
--14:23:33--
http://downloads.openmoko.org/sources/current_libxosd.svn.sourceforge.net_.svnroot.libxosd.source__20071105.tar.gz
Resolving downloads.openmoko.org... 88.198.93.219
Connecting to downloads.openmoko.org|88.198.93.219|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
14:23:34 ERROR 404: Not Found.

NOTE: Fetch
svn://libxosd.svn.sourceforge.net/svnroot/libxosd/source;module=current;proto=https
co: RCS/{20071105},v: No such file or directory
co: https://libxosd.svn.sourceforge.net/svnroot/libxosd/source/RCS/current,v: No
such file or directory
co: RCS/current,v: No such file or directory
NOTE: Task failed: Fetch failed: Fetch command export
PATH=/home/moko/build/tmp/staging/i686-linux/bin/arm-linux:/home/moko/build/tmp/staging/i686-linux/bin:/home/moko/build/tmp/cross/bin:/usr/lib/qt-3.3/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin;
${FETCHCMD_svn} co -r {20071105}
https://libxosd.svn.sourceforge.net/svnroot/libxosd/source/current current
failed with signal 1, output:

NOTE: package libxosd-2.2.15+svn20071105-r4: task do_fetch: failed
ERROR: TaskFailed? event exception, aborting
NOTE: package libxosd-2.2.15+svn20071105: failed
ERROR: Build of /home/moko/oe/packages/libxosd/libxosd_svn.bb do_fetch failed
ERROR: Task 2363 (/home/moko/oe/packages/libxosd/libxosd_svn.bb, do_fetch) failed
NOTE: Tasks Summary: Attempted 772 tasks of which 770 didn't need to be rerun
and 1 failed.
ERROR: '/home/moko/oe/packages/libxosd/libxosd_svn.bb' failed

We are not able to proceed further due to this error.

Please help me resolve this build issue.

Thanks,
Rishikesh

Change History

comment:1 Changed 11 years ago by rishi_date@…

  • Severity changed from major to critical

comment:2 Changed 11 years ago by rishi_date@…

  • Component changed from OE bitbake recipes / build system to autobuilds

comment:3 Changed 11 years ago by mickey@…

I can't reproduce this. Still a problem for you?

comment:4 Changed 11 years ago by rishi_date@…

Yes, we faced the same problem with the Nov 19th build (OE.mtn) as well.

From the build log, we guess that the cause of the error is the absence of
current_libxosd.svn.sourceforge.net_.svnroot.libxosd.source<current_date>.tar.
gz not present on the downloads URL (http://downloads.openmoko.org/sources/).

Is there anything that you are doing which is not mentioned in the
article "Building OpenMoko? from scratch" on OpenMoko? Wiki?

Thanks for the help.
Rishikesh

comment:5 Changed 11 years ago by mickey@…

Somehow it looks like your variables don't get expanded. Are you using Bitbake
1.8? Which OS/shell are you on? The 404 on downloads.openmoko.org is not an
error, since it's just the mirror. It should fallback to read from upstream
afterwards.

On an unrelated note, why is libxosd getting built? Are you not building OM2007.2?

comment:6 Changed 11 years ago by rishi_date@…

Yes, I am using Bitbake 1.8. I use FC6 with the bash shell.

Though I am building OM2007.2, libxosd is getting build as a part of the build
process of the "openmoko-devel-image". As I mentioned in the earlier post I am
following the instructions given on openmoko wiki article "Building OpenMoko?
from Scratch". I am not diverting from it.

What I have done is downloaded the OE.mtn as on Nov 19 and expanded the mtn
file to get the OM2007.2 directory . Hence I claimed it is OM2007.2 which I am
building.

I am not getting a clue of what might have gone wrong.

Thanks,
Rishikesh

comment:7 Changed 11 years ago by john_lee@…

Could you please use the OM repo (the latest MokoMakefile? uses it by default)
and see if the problem still exists?

comment:8 Changed 11 years ago by john_lee@…

  • Status changed from new to closed
  • Resolution set to worksforme

It seems the problem doesn't exist anymore.

Note: See TracTickets for help on using tickets.