Ticket #994 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

openmoko-today2_svn.openmoko.org_.trunk.src.target.OM-2007.2.applications_3287_.tar.gz missing

Reported by: ryuch@… Owned by: mickey@…
Priority: high Milestone:
Component: Autobuilds / Snapshots Version: unspecified
Severity: normal Keywords:
Cc: buglog@…, ryuch@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

OE Build Configuration:
BB_VERSION = "1.8.8"
OE_REVISION = "ad2043623d14a0f9a588eeda0af91870edc25fa1"
TARGET_ARCH = "arm"
TARGET_OS = "linux-gnueabi"
MACHINE = "fic-gta01"
DISTRO = "openmoko"
DISTRO_VERSION = "P1-Snapshot-20071106"
TARGET_FPU = "soft"

NOTE: Resolving missing task queue dependencies
NOTE: preferred version 2.5 of glibc not available (for item
virtual/arm-angstrom-linux-gnueabi-libc-for-gcc)
NOTE: multiple providers are available for virtual/libqte2 (qte-mt-static, qte,
qte-mt);
NOTE: consider defining PREFERRED_PROVIDER_virtual/libqte2
NOTE: Preparing runqueue
NOTE: Executing runqueue
NOTE: Running task 1893 of 5043 (ID: 282,
/home/ryuch/moko/openembedded/packages/openmoko2/openmoko-today2_svn.bb, do_fetch)
NOTE: package openmoko-today2-0.1.0+svnr3287: started
NOTE: package openmoko-today2-0.1.0+svnr3287-r2: task do_fetch: started
NOTE: fetch
http://downloads.openmoko.org/sources/openmoko-today2_svn.openmoko.org_.trunk.src.target.OM-2007.2.applications_3287_.tar.gz
--22:32:15--
http://downloads.openmoko.org/sources/openmoko-today2_svn.openmoko.org_.trunk.src.target.OM-2007.2.applications_3287_.tar.gz

=>

`/home/ryuch/moko/sources/openmoko-today2_svn.openmoko.org_.trunk.src.target.OM-2007.2.applications_3287_.tar.gz'
Resolving downloads.openmoko.org... 88.198.93.219
Connecting to downloads.openmoko.org|88.198.93.219|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
22:32:16 ERROR 404: Not Found.

Change History

comment:1 Changed 11 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to invalid

This is by design and not a problem. OpenEmbedded? first tries to download a
tarball from your CVS_TARBALL_STASH, then falls back to downloading from upstream.

comment:2 Changed 11 years ago by ryuch@…

  • Status changed from closed to reopened
  • Resolution invalid deleted

Following the previous message, it stops with the below message.
As you mentioned it falls back to SVN, but finally it also fails.

---
NOTE: Update
svn://svn.openmoko.org/trunk/src/target/OM-2007.2/applications;module=openmoko-today2;proto=http

Fetching external item into 'libkoto'
External at revision 346.

Fetching external item into 'libtaku'
External at revision 1802.

Fetching external item into 'src/inotify'
svn: URL
'http://svn.o-hand.com/repos/matchbox/trunk/matchbox-desktop-2/src/inotify'
doesn't exist
NOTE: Task failed: Fetch failed: Fetch command export
PATH=/home/ryuch/moko/build/tmp/staging/x86_64-linux/bin/arm-angstrom-linux-gnueabi:/home/ryuch/moko/build/tmp/staging/x86_64-linux/bin:/home/ryuch/moko/build/tmp/cross/bin:/home/ryuch/moko/bitbake/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games;
/usr/bin/env svn update -r 3287 failed with signal 1, output:

Fetching external item into 'libkoto'
External at revision 346.

Fetching external item into 'libtaku'
External at revision 1802.

Fetching external item into 'src/inotify'

NOTE: package openmoko-today2-0.1.0+svnr3287-r2: task do_fetch: failed
ERROR: TaskFailed? event exception, aborting
NOTE: package openmoko-today2-0.1.0+svnr3287: failed
ERROR: Build of
/home/ryuch/moko/openembedded/packages/openmoko2/openmoko-today2_svn.bb do_fetch
failed
ERROR: Task 282
(/home/ryuch/moko/openembedded/packages/openmoko2/openmoko-today2_svn.bb,
do_fetch) failed
NOTE: Tasks Summary: Attempted 1892 tasks of which 1892 didn't need to be rerun
and 1 failed.
ERROR: '/home/ryuch/moko/openembedded/packages/openmoko2/openmoko-today2_svn.bb'
failed
make: * [openmoko-devel-image] Error 1

comment:3 Changed 11 years ago by mickey@…

Yes, this is something completely different and due to upstream (O-Hand, in this
case) having made some reorganizations on their svn server.

This can be fixed by bumping the SRCREV for openmoko-today2 (I guess
org.openembedded.dev has already made this, so you might as well just mtn pull
and mtn update).

Please understand that this is neither a bug in OE nor OM. Upstream is out of
our control and sometimes they do strange things to their source locations. The
best we can do is mirror the sources, but if they don't exist (as in this very
case), we can't mirror but just wait until upstream fixes it or bump revisions
and hope it has been fixed in the meantime.

comment:4 Changed 11 years ago by ryuch@…

  • Status changed from reopened to closed
  • Resolution set to fixed

It was fixed.

Note: See TracTickets for help on using tickets.