Ticket #998 (closed defect: community)

Opened 9 years ago

Last modified 8 years ago

Keyboard autorepeat is too twitchy

Reported by: cwixon@… Owned by: mickey
Priority: high Milestone:
Component: openmoko-keyboard Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

The onscreen keyboard has an autorepeat, so if you hold your stylus down, it
will start to repeat after a short delay. This is great for editing long
command lines, for example.

But it stops autorepeating if stylus movement is detected, and the threshold is
very, very low. So I can hold on an arrow key and the result is a bit
unpredictable:

  • I might get no autorepeat at all, because of some minor jitter from the

touchscreen;

  • I might get autorepeat as long as I want, which is rare; or
  • I might get a few characters' worth of autorepeat, then it stops.

Change History

comment:1 Changed 9 years ago by roh

  • Owner changed from mickey@… to mickeyl

comment:2 Changed 8 years ago by roh

  • Owner changed from mickeyl to mickey

comment:3 Changed 8 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to community
Note: See TracTickets for help on using tickets.