Ticket #1011 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

When running qemu there are many USB DataOverrun messages

Reported by: openmoko@… Owned by: balrogg@…
Priority: high Milestone:
Component: qemu-neo1973 Version: current svn head
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Using my most recent build of OpenMoko? (2007-11-15) running in qemu outputs many

"usb-ohci: DataOverrun? -3 > 17"

messages at a tremendous rate. It does not appear to adversely affect the
virtual machine although I have done nothing more than play with some of the apps.

Change History

comment:1 Changed 11 years ago by balrogg@…

  • Owner changed from dodji@… to balrogg@…

comment:2 Changed 11 years ago by balrogg@…

  • Status changed from new to closed
  • rep_platform changed from PC to Neo1973
  • Resolution set to fixed

Are you sure you're using 2007-11-15 qemu code?
I thought I had fixed this on 2007-11-13. It wasn't really a bug, it's more a
bluez issue with polling the bluetooth dongle's SCO and ACL endpoints in a loop
and it happens on real bluetooth dongles too. I made the qemu bt dongle always
return zero bytes instead of a STALL or NACK to quite the message. It also
revealed some signedness issues in the OHCI usb host and I (believe I) fixed
them upstream. All this was caused by the recently introduced isochronous
transfers support in upstream, which earlier just quietly failed.

Please check that it still happens with current qemu and if so, please reopen.

comment:3 Changed 11 years ago by openmoko@…

Rebuilt qemu this morning. It doesn't spam my terminal any more.

Note: See TracTickets for help on using tickets.