Ticket #1021 (closed defect: fixed)

Opened 11 years ago

Last modified 2 years ago

xserver-kdrive

Reported by: yoyo@… Owned by: mickey@…
Priority: high Milestone:
Component: Xfbdev (kdrive), Xglamo Version: current svn head
Severity: normal Keywords: VERIFIED
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

during compilation:
#$ make openmoko-devel-image

error popup:


| then mv -f ".deps/renderedge.Tpo" ".deps/renderedge.Plo"; else rm -f
".deps/renderedge.Tpo"; exit 1; fi
| arm-angstrom-linux-gnueabi-gcc -march=armv4t -mtune=arm920t -DHAVE_CONFIG_H
-I. -I. -I../include -I../include -I../include -I../include -I../include
-I../include -I../include -I../include
-isystem/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/include
-DHAVE_DIX_CONFIG_H -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT
-I/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/include
-I/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/include/X11/Xtrans
-I/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/include/freetype2
-I../include -I../include -I../Xext -I../composite -I../damageext -I../xfixes
-I../Xi -I../mi -I../miext/shadow -I../miext/damage -I../render -I../randr
-I../fb -isystem/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/include
-fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os -MT
renderedge.lo -MD -MP -MF .deps/renderedge.Tpo -c renderedge.c -fPIC -DPIC -o
.libs/renderedge.o
| In file included from
/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/include/X11/extensions/renderproto.h:30,
| from glyphstr.h:28,
| from picturestr.h:29,
| from renderedge.h:28,
| from renderedge.c:29:
|
/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/include/X11/extensions/render.h:29:
error: expected '=', ',', ';', 'asm' or 'attribute' before 'Glyph'
|
/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/include/X11/extensions/render.h:30:
error: expected '=', ',', ';', 'asm' or 'attribute' before 'GlyphSet?'
|
/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/include/X11/extensions/render.h:31:
error: expected '=', ',', ';', 'asm' or 'attribute' before 'Picture'
|
/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/include/X11/extensions/render.h:32:
error: expected '=', ',', ';', 'asm' or 'attribute' before 'PictFormat?'
| In file included from picturestr.h:29,
| from renderedge.h:28,
| from renderedge.c:29:
| glyphstr.h:141: error: expected declaration specifiers or '...' before 'Glyph'
| glyphstr.h:144: error: expected declaration specifiers or '...' before 'Glyph'
| glyphstr.h:147: error: expected declaration specifiers or '...' before 'Glyph'
| In file included from renderedge.h:28,
| from renderedge.c:29:
| picturestr.h:499: error: expected ')' before 'pid'
| picturestr.h:643: error: expected ')' before 'pid'
| picturestr.h:648: error: expected ')' before 'pid'
| picturestr.h:657: error: expected ')' before 'pid'
| picturestr.h:668: error: expected ')' before 'pid'
| make[2]: * [renderedge.lo] Error 1
| make[2]: Leaving directory
`/home/moko/build/tmp/work/armv4t-angstrom-linux-gnueabi/xserver-kdrive-1_1.3.0.0-r21/xorg-server-1.3.0.0/render'
| make[1]:
* [all-recursive] Error 1
| make[1]: Leaving directory
`/home/moko/build/tmp/work/armv4t-angstrom-linux-gnueabi/xserver-kdrive-1_1.3.0.0-r21/xorg-server-1.3.0.0'
| FATAL: oe_runmake failed
NOTE: Task failed:
/home/moko/build/tmp/work/armv4t-angstrom-linux-gnueabi/xserver-kdrive-1_1.3.0.0-r21/temp/log.do_compile.5597
NOTE: package xserver-kdrive-1_1.3.0.0-r21: task do_compile: failed
ERROR: TaskFailed? event exception, aborting
NOTE: package xserver-kdrive-1.3.0.0: failed
ERROR: Build of
/home/moko/openembedded/packages/xorg-xserver/xserver-kdrive_1.3.0.0.bb
do_compile failed
ERROR: Task 651
(/home/moko/openembedded/packages/xorg-xserver/xserver-kdrive_1.3.0.0.bb,
do_compile) failed
NOTE: Tasks Summary: Attempted 4726 tasks of which 4721 didn't need to be rerun
and 1 failed.
ERROR: '/home/moko/openembedded/packages/xorg-xserver/xserver-kdrive_1.3.0.0.bb'
failed
make: * [openmoko-devel-image] Error 1


somting is wrong with armv4t headears?

Change History

comment:1 Changed 11 years ago by graeme@…

This is due to renderproto 0.9.3 being in your staging instead of 0.9.2, I am
having trouble working out how this happened though.

Can you try a clean build?

comment:2 Changed 11 years ago by cm@…

i tried changing PREFERRED_VERSION_renderproto ?= "0.9.2" in
openembedded/conf/distro/include/angstrom-2007-preferred-versions.inc, then
doing bitbake -c rebuild renderproto and xserver-kdrive. That got me past it.

comment:3 Changed 11 years ago by graeme@…

  • Status changed from new to closed
  • Resolution set to fixed

This appears to be a transient bug, it doesnt occur with the current metadata
but you might need to clean renderproto before a rebuild.

comment:4 Changed 11 years ago by yoyo@…

  • Keywords VERIFIED added

after making:
make clean-package-renderproto; make clean-package-xserver-kdrive

bug disapire :)

THX Graeme Gregory

comment:5 Changed 2 years ago by Chassmetly

Viagra 100mg Pfizer <a href=http://priligy.ccrpdc.com/dapoxitine.php>Dapoxitine</a> Precios De Cialis Buy Pet Chlorampheticol <a href=http://viag1.xyz/cheap-generic-viagra.php>Cheap Generic Viagra</a> Amoxil Asthma Zithromax For Gastric Emptying <a href=http://kama1.xyz/kamagra-order.php>Kamagra Order</a> Propecia Divisas Viagra And Oxycodone <a href=http://kama1.xyz/low-cost-kamagra-online.php>Low Cost Kamagra Online</a> Pacific Care Prescriptions Cialis Anwendung <a href=http://cial1.xyz/cialis-40mg.php>Cialis 40mg</a> Amoxicillin And Pediatric Dosage Keflex Creatinine <a href=http://cial1.xyz/tadalafil-tablets.php>Tadalafil Tablets</a> Prezzo Cialis Svizzera Acheter Lioresal 10mg <a href=http://zol1.xyz/buy-zoloft-cheap.php>Buy Zoloft Cheap</a> Come Comprare Viagra Senza Ricetta Medica Viagra Tarif Pharmacie <a href=http://cial5mg.xyz>Buy Cialis</a> Cialis Ricetta Online Fluoxetine Where To Order With Free Shipping <a href=http://kama1.xyz/kamagra-online-cheap.php>Kamagra Online Cheap</a> Le Viagra En Libre Propecia Aparato Digestivo <a href=http://levitra.ccrpdc.com/levitra-cost-uk.php>Levitra Cost Uk</a> Amoxicillin Dogs Bone Infection Bulgaria Buy Viagra <a href=http://zol1.xyz/zoloft-50mg.php>Zoloft 50mg</a> Tadalafil Cialis Order Prevacid Otc <a href=http://cial1.xyz/cialis-price.php>Cialis Price</a> Levitra Bestellen Cialis 10 Mg Propiedades <a href=http://zol1.xyz/buy-zoloft-cheap.php>Buy Zoloft Cheap</a> Buy Genuine Xenical Online Tadalafil India <a href=http://cial1.xyz/order-cialis-tablets.php>Order Cialis Tablets</a> Zithromax Affect Birth Control Ompranyt Online Uk <a href=http://zol1.xyz/purchase-cheap-zoloft.php>Purchase Cheap Zoloft</a> Levitra Club Tadapox Online In Usa <a href=http://viag1.xyz/viagra-cost.php>Viagra Cost</a> Blood Pressure Pills Online Sertraline No Prescription <a href=http://kama1.xyz/kamagra-soft-tablets.php>Kamagra Soft Tablets</a> Quality Rx Levitra How To Take <a href=http://zol1.xyz/generic-zoloft.php>Generic Zoloft</a> Buy Canadian Cialis Vendita Viagra In Farmacia <a href=http://cial5mg.xyz/cost-of-cialis.php>Cost Of Cialis</a> Amoxicillin The Right Dose For Seniors Propecia Dry Scalp <a href=http://cial5mg.xyz/purchase-cheap-cialis.php>Purchase Cheap Cialis</a> Cialis Instrucciones Get Propecia Prescription <a href=http://kama1.xyz/generic-kamagra-online.php>Generic Kamagra Online</a> Buy Levitra Wholesale How Last Longer <a href=http://zoloft.ccrpdc.com/cheapest-zoloft.php>Cheapest Zoloft</a> Propecia Pdf Prescription For Diflucan <a href=http://cial1.xyz/generic-for-cialis.php>Generic For Cialis</a> Wirkung Viagra Lasst Nach Uscanadiandiscountcialis <a href=http://cial1.xyz/cost-of-cialis.php>Cost Of Cialis</a> Finasteride Natural Propecia Viagra Urgente <a href=http://cial1.xyz/cialis-order.php>Cialis Order</a> Doxycycline 20mg For Sale Will Cephalexin Heal Tooth Absess <a href=http://kama1.xyz/order-kamagra-online-usa.php>Order Kamagra Online Usa</a> Propecia Al Femminile Levitra Derniere Minute <a href=http://zol1.xyz/zoloft-implicane.php>Zoloft Implicane</a> How Can I Last Longer Viagra Frau Nasenspray <a href=http://kama1.xyz/order-kamagra.php>Order Kamagra</a> Online Renova No Prescription Generic Viagra Overnight Shipping <a href=http://cial5mg.xyz/brand-cialis.php>Brand Cialis</a> Isotretinoin 20mg for sale Online Harmacy <a href=http://kama1.xyz/cheap-kamagra-uk.php>Cheap Kamagra Uk</a> Acheter Levitra En Streaming Which Store Has Cheap 75 Mcg Synthroid <a href=http://kama1.xyz/price-of-kamagra.php>Price Of Kamagra</a> Cheap Cialis No Rx Propecia Ersatzmedikament <a href=http://viag1.xyz/viagra-dosage.php>Viagra Dosage</a> What Is Amoxicillin 875 Mg How To Buy Macrobid <a href=http://zol1.xyz/cheap-zoloft-50mg.php>Cheap Zoloft 50mg</a> Cialis V Levitra Xenical Over The Counter <a href=http://viag1.xyz/viagra-online-cheap.php>Viagra Online Cheap</a> Buy Cialis Online Safely Cialis En Prise Quotidienne <a href=http://zol1.xyz/zoloft-free-offer.php>Zoloft Free Offer</a> Climen No Prescription Cozaar <a href=http://viag1.xyz/cheap-viagra-overnight.php>Cheap Viagra Overnight</a> Cialis Ulcera Plus Tapeworms Tablet Next Day <a href=http://cial1.xyz/cialis-cost.php>Cialis Cost</a> Nolvadex Sans Ordonance Viagra Generico In Italia <a href=http://kamagra.ccrpdc.com/kamagra-tablet.php>Kamagra Tablet</a> Gleevec Cheapest Levitra Online <a href=http://zol1.xyz/zoloft-online.php>Zoloft Online</a> Propecia Estrogenos Viagra Cialis Combo Pack <a href=http://cial5mg.xyz/cialis-professional.php>Cialis Professional</a> Clomid Et Debut De Grossesse Cialis Im Urlaub Kaufen <a href=http://viag1.xyz/viagra-discount-sales.php>Viagra Discount Sales</a> Preis Viagra Sildenafil Is Alli Back On The Market Yet 2014 <a href=http://cialis.ccrpdc.com>Buy Cialis</a> Buy Pet Chlorampheticol Informacion Sobre Priligy <a href=http://cial5mg.xyz/prices-cialis.php>Prices Cialis</a> Vardenafil Generic Vs Brand

Note: See TracTickets for help on using tickets.