Ticket #1039 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

[xglamo] xglamo corruption

Reported by: dodji@… Owned by: dodji@…
Priority: high Milestone:
Component: Xfbdev (kdrive), Xglamo Version: unspecified
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

For some people, xglamo has some artifacts when scrolling.

Typically, lines of the scrolled region are actually lines that belongs to the
region coming right after the scrolled region.

Change History

comment:1 Changed 11 years ago by olv@…

  • Owner changed from mickey@… to olv@…

comment:2 Changed 11 years ago by dodji@…

  • Status changed from new to assigned

It looks like the problem was due to the byte stride of the pixmaps were (aka
pitch) 2 bytes aligned and that was introducing an artifact.

This patch
http://folks.o-hand.com/dodji/omoko/xglamo/01-xglamo-scrolling-artifact-fix.patch
seems to fix the problem.

We need to push it into OE/Moko now.

comment:3 Changed 11 years ago by dodji@…

  • Owner changed from olv@… to dodji@…
  • Status changed from assigned to new

comment:4 Changed 11 years ago by dodji@…

  • Summary changed from xglamo corruption to [xglamo] xglamo corruption

comment:5 Changed 11 years ago by dodji@…

  • Status changed from new to closed
  • Resolution set to fixed

The patch got pushed to OE.

Note: See TracTickets for help on using tickets.