Ticket #1132 (closed defect: later)

Opened 11 years ago

Last modified 11 years ago

when hands-free mode is on, the mic is muted

Reported by: kresp0@… Owned by: chris@…
Priority: high Milestone:
Component: Applications & Dependencies Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

when hands-free mode is on (without the handset), the mic on the neo is muted.

Change History

comment:1 Changed 11 years ago by sean_chiang@…

  • Owner changed from thomas@… to chris@…

comment:2 Changed 11 years ago by chris@…

  • Status changed from new to assigned

Just confirmed this, will take a look

comment:3 Changed 11 years ago by chris@…

Something must be wrong with the /etc/gsmspeakerout.state settings, but I don't
know enough about the neo's audio setup to debug this (well, perhaps if I spent
a long time on it..). There should be someone else with knowledge in this area
that can comment? e.g. whoever wrote this state file?

comment:4 Changed 11 years ago by chris@…

  • Component changed from openmoko-dialer to Applications & Dependencies

comment:5 Changed 11 years ago by alphaone@…

The mic is disabled because enabling it will result in audio feedback. That's
why I called it speakerout.state and not handsfree. :-)

For handsfree we would need some sort of echo cancellation either in hardware or
in software, but I don't think that we can do it in hardware at the moment or
work particularly well in software.

comment:6 Changed 11 years ago by chris@…

  • Status changed from assigned to closed
  • Resolution set to later

Marking this as later as it seems it's something not easily solved in software.
Thanks for the comment Daniel

Note: See TracTickets for help on using tickets.