Ticket #1140 (closed defect: fixed)

Opened 11 years ago

Last modified 20 months ago

u-boot menu text is not displayed correctly (GTA01Bv4)

Reported by: mail@… Owned by: willie_chen@…
Priority: high Milestone:
Component: u-boot Version: current svn head
Severity: normal Keywords:
Cc: buglog@…, werner@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

On recent u-boots built from the "openmoko_svn.bb" recipe, the text in the
u-boot menu is not displayed properly and is almost unreadable. Please see the
attached screen capture. The menu itself works OK, and there are no problems
with the boot messages from the Linux kernel or with the OpenMoko? GUI (so it's
not a physical problem with my screen).

The screen capture was taken with a slightly older build of the program, but I
have confirmed it on a fresh build of
u-boot-gta01bv4-1.3.1+git20071220+svnr3692-r1.bin . My only modifications from
the standard recipe are a patch for #799 (SD-booting) and a fix for the
"localversion" string, and I can't see any way that either of these could cause
a video/font problem.

Attachments

menu.png (3.2 KB) - added by mail@… 11 years ago.
Screen capture
om1140.patch (1.0 KB) - added by mail@… 11 years ago.
Patch

Change History

Changed 11 years ago by mail@…

Screen capture

Changed 11 years ago by mail@…

Patch

comment:1 Changed 11 years ago by mickey@…

Confirmed the fix -- thanks!

comment:2 Changed 11 years ago by werner@…

Hmm, I wonder if we shouldn't just simply turn off HWSWP in LCDCON5
(board/neo1973/common/jbt6k74.c) and adjust the splash screen image instead.
Not only would this avoid the SHORTSWAP32 kludge, but it would also make
console output a little faster.

Drawback: splash screens will look a little funny (until updated).

comment:3 Changed 11 years ago by werner@…

  • Cc werner@… added

comment:4 Changed 11 years ago by werner@…

  • Status changed from new to closed
  • Resolution set to fixed

My proposed fix (disabling HWSWP) is in r3774, along with an update of
host/splash/splashimg.pl

The latter now needs to be invoked with the option -swap to produce a valid
image. I didn't update the devirginator yet, because there's a larger set of
changes coming that still need verification.

comment:5 Changed 20 months ago by Larcadist

Comment Avoir Du Viagra Sans Ordonnance http://cialtobuy.com - generic cialis Amoxicillin Differs From Ampicillin
Effect Of Propecia Price Generic Viagra Cialis Tablets 10mg
Kamagra Francia <a href=http://cialtobuy.com >cialis price</a> Buy Orlistat Online

Note: See TracTickets for help on using tickets.