Ticket #1191 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

[PATCH] openmoko-terminal2: Tab or window is not closed when hitting EOF or exit

Reported by: haakeyar-mailinglists@… Owned by: buglog@…
Priority: high Milestone:
Component: openmoko-terminal Version: 2007.2
Severity: minor Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

When you enter exit or eof (hit D), the terminal is not exited, but this
message is printed to stdout: "unhandled eof".

Steps to reproduce:
1) Run openmoko-terminal2 from the command line.
2) Hit D or write "exit" and press enter.

Actual results:
The terminal prints a newline and you are unable to type anything more in the
terminal in this tab. "unhandled eof" is written to stdout.

Expected results:
If there are several tabs, the current tab should be closed. If there is only
one tab, openmoko-terminal2 should be exited.

The patch:
It is created from revision 3886. This is a suggested solution, but I do not
have previous experience with Vala (or C), so there could be better solutions. I
have only compiled and tested it on a pc, I have not tried to cross-compile and
run it on the neo, but unless there are some strange closs-platform bugs, I
assume it should work.

Attachments

openmoko-terminal2.diff (3.5 KB) - added by haakeyar-mailinglists@… 11 years ago.
Patch against revision 3886

Change History

Changed 11 years ago by haakeyar-mailinglists@…

Patch against revision 3886

comment:1 Changed 11 years ago by haakeyar-mailinglists@…

  • Severity changed from normal to minor

comment:2 Changed 11 years ago by mickey@…

  • Status changed from new to assigned

comment:3 Changed 11 years ago by mickey@…

  • Status changed from assigned to closed
  • Resolution set to fixed

Thanks for patch. I solved it differently though, because I wanted to keep the
encapsulation intact (the tab should not know anything about main). rev 4023.

Note: See TracTickets for help on using tickets.