Ticket #12 (closed defect: fixed)

Opened 12 years ago

Last modified 2 years ago

Boot speed too low (bootloader part)

Reported by: laforge@… Owned by: willie_chen@…
Priority: high Milestone:
Component: u-boot Version: current svn head
Severity: normal Keywords:
Cc: buglog@…, willie_chen@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

The bootloader adds its share of delay to the boot process.

This can be improved by e.g. using an uncompressed kernel in uImage.

Change History

comment:1 Changed 12 years ago by sean_mosko@…

  • Milestone set to Phase 1

Please Motorola Ming (A1200) as your metric.

comment:2 Changed 12 years ago by sean_mosko@…

  • Owner changed from laforge@… to gordon_hsu@…

comment:3 Changed 12 years ago by laforge@…

  • Owner changed from gordon_hsu@… to laforge@…

comment:4 Changed 12 years ago by mickey@…

  • dependson set to 874

comment:5 Changed 11 years ago by willie_chen@…

  • Owner changed from laforge@… to michael@…

comment:6 Changed 11 years ago by willie_chen@…

  • Cc willie_chen@… added

comment:7 Changed 11 years ago by willie_chen@…

  • Owner changed from michael@… to willie_chen@…

comment:8 Changed 11 years ago by andy@…

We need to measure boot time and put numbers on this. A report from nearly a
year ago that it used to be "slow" can't be attacked.

comment:9 Changed 11 years ago by andy@…

Currently on GTA-02 A4 at 200MHz ~19s (~15s at 400MHz) is burnt in U-Boot before
a decompressed Linux actually starts to boot.

We can improve matters a bit by seeing if we can parse the image we are reading
somehow to only read the (currently, 1.5MB) kernel footprint instead of a fixed
2MB block that seems to be the case right now.

Otherwise the raw NAND reading and ECC speed seems to be where the bulk of the
time goes.

comment:10 Changed 11 years ago by anonymous

  • Milestone Phase 1 deleted

Milestone Phase 1 deleted

comment:11 Changed 11 years ago by andy

  • Status changed from new to closed
  • Resolution set to fixed

I think it's about as good as it is going to get. We will be moving off U-Boot into kboot, which will be MUCH faster.

comment:12 Changed 2 years ago by JustDox

Lasix Mexico <a href=http://viag1.xyz/viagra-pill.php>Viagra Pill</a> Levitra Medicamento Para Impotencia Viagra Canada. Shop <a href=http://cial5mg.xyz/low-cost-cialis-online.php>Low Cost Cialis Online</a> Cialis Una Volta Al Giorno Prospecto Cialis <a href=http://cial5mg.xyz/need-to-order-cialis.php>Need To Order Cialis</a> Cialis Lleida Vendita Viagra Milano <a href=http://kama1.xyz/kamagra-cheap.php>Kamagra Cheap</a> Amoxicillin 250mg Capsules Lasix With No Scrpit <a href=http://cial5mg.xyz/shop-cialis-online.php>Shop Cialis Online</a> For Cats Amoxicillin How To Use Voltaren Retard 100mg <a href=http://cial5mg.xyz/cialis-viagra.php>Cialis Viagra</a> Cialis Faut Il Une Ordonnance Acheter Du Viagra Super Actif <a href=http://cial1.xyz/tadalafil-20mg.php>Tadalafil 20mg</a> Propecia 5 Mg For Sale No Get Progesterone Menopause <a href=http://nolvadex.ccrpdc.com/online-nolvadex.php>Online Nolvadex</a> Amoxil Forte Propecia Recalcine <a href=http://viag1.xyz/online-generic-viagra.php>Online Generic Viagra</a> Trouver Levitra En Belgique Cialis Oglasi <a href=http://viag1.xyz/map.php>Sildenafil</a> Clomid Date Ovulation Delta Enterprises Cialis <a href=http://accutane.ccrpdc.com/buy-oratane.php>Buy Oratane</a> Cialis Precio Farmacia Del Ahorro Oct Products Similiar To Lasix <a href=http://propecia.ccrpdc.com/cheapest-propecia-online.php>Cheapest Propecia Online</a> Zithromax Is It Penicillin Cialis Disfunzione Erettile <a href=http://cial1.xyz/buy-cialis-online.php>Buy Cialis Online</a> Can You Buy Z Packs? Buy Viarga Without A Percription <a href=http://viag1.xyz/cheap-viagra-fast.php>Cheap Viagra Fast</a> Acheter Cialis France Cialis Generico Alta Qualita <a href=http://antabuse.ccrpdc.com/how-to-buy-antabuse.php>How To Buy Antabuse</a> Viagra Efecto Prolongado How Safe Is Keflex Antibiotic <a href=http://lasix.ccrpdc.com/lasix-online-store.php>Lasix Online Store</a> Cephalexin Review Kamagra Interdit En France <a href=http://cial1.xyz/how-to-order-cialis.php>How To Order Cialis</a> Levitra Generic 10mg Kamagra Tabletten Bestellen <a href=http://viag1.xyz/viagra-samples.php>Viagra Samples</a> Viagra Pour Femme Avis Misoprostol Cytotec Acheter <a href=http://viag1.xyz/buy-cheap-viagra.php>Buy Cheap Viagra</a> Cialis Cheapest Canada

Note: See TracTickets for help on using tickets.