Ticket #1229 (closed defect: worksforme)

Opened 11 years ago

Last modified 2 years ago

make openmoko-devel-image ERROR

Reported by: yucheng82@… Owned by: mickey@…
Priority: high Milestone:
Component: OE bitbake recipes / build system Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

When i build openmoko with MoKoMakefile? , i catch a error, please help me,
thanks.
yucheng@yucheng0-desktop:/work/moko$ make openmoko-devel-image
( cd build && . ../setup-env && \

( ( bitbake openmoko-devel-image uboot-openmoko )

( bitbake openmoko-devel-image u-boot-openmoko ) ) )

NOTE: Handling BitBake? files: - (5036/5036) [100 %]
NOTE: Parsing finished. 4803 cached, 0 parsed, 233 skipped, 0 masked.
NOTE: build 200802030023: started

OE Build Configuration:
BB_VERSION = "1.8.10"
OE_REVISION = "fbdf8a106f5161fd714dd92d53cf8bd31fa6d8ea"
TARGET_ARCH = "arm"
TARGET_OS = "linux-gnueabi"
MACHINE = "fic-gta01"
DISTRO = "openmoko"
DISTRO_VERSION = "P1-Snapshot-20080202"
TARGET_FPU = "soft"

ERROR: Nothing PROVIDES 'uboot-openmoko' (but '[]' DEPENDS on or otherwise
requires it)
NOTE: Handling BitBake? files: - (5036/5036) [100 %]
NOTE: Parsing finished. 4803 cached, 0 parsed, 233 skipped, 0 masked.
NOTE: build 200802030024: started

OE Build Configuration:
BB_VERSION = "1.8.10"
OE_REVISION = "fbdf8a106f5161fd714dd92d53cf8bd31fa6d8ea"
TARGET_ARCH = "arm"
TARGET_OS = "linux-gnueabi"
MACHINE = "fic-gta01"
DISTRO = "openmoko"
DISTRO_VERSION = "P1-Snapshot-20080202"
TARGET_FPU = "soft"

NOTE: Resolving any missing task queue dependencies
NOTE: preferred version 2.5 of glibc not available (for item virtual/arm-
angstrom-linux-gnueabi-libc-for-gcc)
NOTE: preferred version 0.16.10 of vte not available (for item vte)
NOTE: preferred version 0.10 of hicolor-icon-theme not available (for item
hicolor-icon-theme)
NOTE: preferred version 2007e of tzdata not available (for item tzdata)
NOTE: preferred version 2007e of tzcode-native not available (for item tzcode-
native)
NOTE: preferred version 20070918+git of hal-info not available (for item hal-
info)
NOTE: multiple providers are available for virtual/libqte2 (qte-mt-static,
qte, qte-mt);
NOTE: consider defining PREFERRED_PROVIDER_virtual/libqte2
NOTE: Preparing runqueue
NOTE: Executing runqueue
NOTE: Running task 129 of 5344 (ID:
2748, /work/moko/openembedded/packages/gcc/gcc-cross-initial_4.1.2.bb,
do_patch)
NOTE: package gcc-cross-initial-4.1.2: started
NOTE: package gcc-cross-initial-4.1.2-r13: task do_patch: started
NOTE: Applying patch '100-uclibc-conf.patch'
NOTE: Task failed: Command Error: exit status: 1 Output:
Usage: quilt [--trace[=verbose]] [--quiltrc=XX] command [-h] ...

quilt --version

Commands are:

Global options:

--trace

Runs the command in bash trace mode (-x). For internal debugging.

--quiltrc file

Use the specified configuration file instead of ~/.quiltrc (or
/etc/quilt.quiltrc if ~/.quiltrc does not exist). See the pdf
documentation for details about its possible contents.

--version

Print the version number and exit immediately.

NOTE: package gcc-cross-initial-4.1.2-r13: task do_patch: failed
ERROR: TaskFailed? event exception, aborting
NOTE: package gcc-cross-initial-4.1.2: failed
ERROR: Build of /work/moko/openembedded/packages/gcc/gcc-cross-
initial_4.1.2.bb do_patch failed
ERROR: Task 2748 (/work/moko/openembedded/packages/gcc/gcc-cross-
initial_4.1.2.bb, do_patch) failed
NOTE: Tasks Summary: Attempted 128 tasks of which 128 didn't need to be rerun
and 1 failed.
ERROR: '/work/moko/openembedded/packages/gcc/gcc-cross-initial_4.1.2.bb' failed
make: * [openmoko-devel-image] Error 1
yucheng@yucheng0-desktop:/work/moko$

Change History

comment:1 Changed 11 years ago by rod@…

  • Owner changed from rod@… to mickey@…
  • Component changed from MokoMakefile to OE bitbake recipes / build system

comment:2 Changed 11 years ago by john_lee@…

  • Status changed from new to closed
  • Resolution set to worksforme

It seems OE used the wrong version of quilt. version 0.45 of quilt-native
should be built by OE and be used instead of the one in your host system.

Please make update-makefile && make clobber-openembedded && make update && make
setup
then build again. If the problem still exists please check your local.conf to
see if ASSUME_PROVIDED line exists. If it exists please delete it. Also please
report the linux distribution and the version you're using.

For now close the bug because it seems to be a local problem.

comment:3 Changed 2 years ago by RoberMync

Louer Levitra Pas Cher <a href=http://cial5mg.xyz/cialis-generic.php>Cialis Generic</a> Le Cialis Forum Kamagra France <a href=http://cial1.xyz/buy-online-cialis.php>Buy Online Cialis</a> Sildenafil Mastercard Viagra Achat En Ligne Belgique <a href=http://viag1.xyz/viagra-cost.php>Viagra Cost</a> Viagra Avec Dapoxetine Interaction Of Vitamin D And Amoxicillin <a href=http://cial1.xyz/get-cheap-cialis-online.php>Get Cheap Cialis Online</a> Bentyl With Free Shipping In Internet Overseas Pharmacy Antibiotics Cephalexin <a href=http://cial1.xyz/cialis-order.php>Cialis Order</a> Best Life Rx Pharmacy Ampicillin Uses <a href=http://cial1.xyz/buy-cialis-cheap.php>Buy Cialis Cheap</a> Why Cant I Import Kamagra To Canada Prezzo Kamagra Doctissimo <a href=http://zol1.xyz/generic-zoloft-pricing.php>Generic Zoloft Pricing</a> Opiniones Cialis Propecia Spain Cialis Levitra <a href=http://zol1.xyz/zoloft-cost.php>Zoloft Cost</a> Vente De Propecia Paris Best Price For Generic Cialis <a href=http://cial5mg.xyz/can-i-buy-cialis-online.php>Can I Buy Cialis Online</a> Levitra Taglich Sage And Propecia <a href=http://viag1.xyz/buy-viagra.php>Buy Viagra</a> Amoxicillin The Right Dose Propecia Rogaine <a href=http://zol1.xyz/generic-zoloft-pricing.php>Generic Zoloft Pricing</a> Clomid Louer Acquistare Priligy Senza Ricetta <a href=http://cial1.xyz/tadalafil.php>?Tadalafil</a> Medrol Dose Pack 4 Mg No Rx Cialis Generika Kaufen Erfahrungen <a href=http://viag1.xyz/viagra-for-sale.php>Viagra For Sale</a> Viagra Rezeptfrei Bestellen De Can I Purchase Acticin <a href=http://prednisone.ccrpdc.com/online-deltasone.php>Online Deltasone</a> How Long Is Zithromax Good For Acheter Priligy Thaр“р‡lande <a href=http://xenical.ccrpdc.com/xenical-orlistat-1.php>Xenical Orlistat</a> Dapoxetina Menarini Prix Du Propecia En Belgique <a href=http://lasix.ccrpdc.com/comprare-lasix.php>Comprare Lasix</a> Buying Generic Viagra Online Reviews Buy Tamoxifen Online Uk <a href=http://prozac.ccrpdc.com/fluoxetine.php>?Fluoxetine</a> Clomid Magasin L Homme World Best Online Pharmacy Review <a href=http://viag1.xyz/viagra-dosage.php>Viagra Dosage</a> Who Discovered Amoxicillin Levitra Non Funziona <a href=http://cial1.xyz/cialis-online-prices.php>Cialis Online Prices</a> Overnight Meds Online

Note: See TracTickets for help on using tickets.