Ticket #130 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

GTK Popup menus size incorrectly

Reported by: sean_mosko@… Owned by: mickey@…
Priority: high Milestone:
Component: Theming - Gtk+ Version: unspecified
Severity: normal Keywords:
Cc: buglog@…, thomas@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Popup menus should look exactly like the graphic designer's layouts. Right now
they size according to the larger item in the popup menu's list.

Change History

comment:1 Changed 12 years ago by ken_zhao@…

  • Owner changed from ken_zhao@… to mickey@…

comment:2 Changed 12 years ago by mickey@…

  • Cc thomas@… added

Thomas, do we need to patch Gtk+ for that or can we do it in another way? The
Gtk+ menu width should always be roughly 1/2*screensize-someoffset

comment:3 Changed 12 years ago by mickey@…

any news on that?

comment:4 Changed 12 years ago by thomas@…

A GtkMenu? is derived from GtkWidget?, so gtk_widget_set_size_request () can be
called on it to set a minimum width and height.

comment:5 Changed 12 years ago by mickey@…

ah, right. So I can probably realize this inside openmoko-libs without the
need for patching Gtk or needing a special "popup-menu-now" function. Thanks
for the pointer.

comment:6 Changed 12 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to fixed

fixed in r1641.

I couldn't use gtk_widget_set_size_request() though because this didn't set the
minimum values, but forced them (even if the contained text was larger).

Therefore I connected the size-request signal to override the requisition with
size of menubox / 2.5.

Note: See TracTickets for help on using tickets.