Ticket #1363 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Qemu on the internet

Reported by: nikosverschore@… Owned by: openmoko-devel@…
Priority: high Milestone:
Component: qemu-neo1973 Version: unspecified
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

On the site (
http://wiki.openmoko.org/wiki/Qemu#Setting_up_Internet_connection_for_your_qemu_neo:
) stands an excellent manual for getting internet on the emulator qemu. But I
can't go past the command:
route add default gw 192.168.68.1

The emulated neo gives the following error:
route: SIOCADDRT: No such process

I've checked with the ifconfig and I've noticed that the loopback is the only
network 'connection'. (usb0 is down because we used the command ifdown usb0).
Normally I would expect another network device, so the route command shouldn't
give errors.

How can I still get internet on the neo (without having to setup the emulated
usb connection, because I and many others don't like messing in my kernel)

Nikos

Change History

comment:1 Changed 11 years ago by balrogg@…

I believe this chapter (Setting up Internet Connection..) assumes that you've
already set up a normal network connection between the Neo1973 and the PC, and
it only covers setting up a NAT routing to the internet over that (pre-existing)
connection. (I haven't tried these instructions)

comment:2 Changed 11 years ago by nikosverschore@…

  • Status changed from new to closed
  • Resolution set to fixed

Thanks, you're right. After making the serial connection and trying it again, it
was solved.

I have changed the wiki, so nobody forgets it.

Note: See TracTickets for help on using tickets.