Ticket #1374 (closed defect: invalid)

Opened 11 years ago

Last modified 11 years ago

Xglamo forward broken

Reported by: mickey@… Owned by: openmoko-devel@…
Priority: high Milestone:
Component: Xfbdev (kdrive), Xglamo Version: unspecified
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

see attachement. This works with Xfbdev.

Attachments

garbled-xforward.png (214.7 KB) - added by mickey@… 11 years ago.
picture of broken X forwarding

Change History

Changed 11 years ago by mickey@…

picture of broken X forwarding

comment:1 Changed 11 years ago by dodji@…

Sorry, what are you doing exactly ?

on the device, are you doing:

export DISPLAY=yourpcadress:0

So that things get displayed on your desktop instead ?

comment:2 Changed 11 years ago by mickey@…

Yes.

comment:3 Changed 11 years ago by dodji@…

Hmmh. Okay, I will try to reproduce and let you know.

Thanks for reporting this.

comment:4 Changed 11 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to invalid

Werner indicated rather something about the libs broken (because it looked like
a colordepth mismatch) and he's right. The actual fault is the EFL x11-16 engine
which obviously does some shortcuts to gain speed. With the usual EFL x11(32)
engine it forwarding works ok. Sorry for the noise.

comment:5 Changed 11 years ago by raster@…

the 16bit engines assumes the display is 16bpp and the same endianness/bit order
as the client. it assumes local-only operation, so forwarding to a non-16bit
display and/or not the same endianess will not work. yes - it's a shortcut by
that engine. the 32bit engine does do things "right". so yes - leave as invalid.

Note: See TracTickets for help on using tickets.