Ticket #1379 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

KDrive doesn't build

Reported by: openmoko@… Owned by: openmoko-devel@…
Priority: high Milestone:
Component: Xfbdev (kdrive), Xglamo Version: current svn head
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:


I tried to build the newest OpenMoko?. Once I tried for x86 to use xephyr, then I
tried the build for arm to use qemu. Both times I got errors from kdrive. Here
the outputs of both proceses:

(I hope I've written all necesary things. Maybe someone can write a Wikipage on
how to write good bug reports to help people who are new in using Bugtrackers)

Change History

comment:1 Changed 11 years ago by adelthebeast@…

'm using ubuntu 7.10 and I'm trying to build openmoko but that error arises
http://pastebin.ubuntu.com/9804/ , which is the same as your error but I was
trying to build using mokomake file by typing "make openmoko-devel-image", I've
tried searching for the same error on bugzilla but non where found, I only found
someone have the same problem on http://pastebin.ca/995933 but there where no

comment:2 Changed 11 years ago by openmoko@…

I'm also using MokoMakefile? with the same comand.

comment:3 Changed 11 years ago by adelthebeast@…

the solution of the problem:
edit line 120 of openembedded/packages/xorg-xserver/xserver-kdrive-common.inc
to: ac_cv_fileusr_share_sgml_X11_defs_ent=no"

comment:4 Changed 11 years ago by openmoko@…

Thanks Mohamed, this change solved my Problem. I hope this will be fixed in the
repository too.

comment:5 Changed 11 years ago by raster

  • Status changed from new to closed
  • Resolution set to fixed

fixed - see above comments.

Note: See TracTickets for help on using tickets.