Ticket #144 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

when phone is hard-rebooted, Xfbdev complains about /tmp/.X0-lock

Reported by: laforge@… Owned by: mickey@…
Priority: high Milestone:
Component: Xfbdev (kdrive), Xglamo Version: current svn head
Severity: major Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

we might just delete this in some init script. I'm sure OE has some standard
method of dealing with this.

Change History

comment:1 Changed 12 years ago by stefan@…

Harald has added a workaround for this in svn r1195:

+ # an ugly hack to make sure Xserver will always start, even
+ # after unclean shutdown
+ [ -e /tmp/.X0-lock ] && rm /tmp/.X0-lock

comment:2 Changed 12 years ago by philippedeswert@…

  • dependson set to 253

comment:3 Changed 12 years ago by mickey@…

/tmp usually is a tmpfs hence the problem doesn't show up. However, due to a
related bug (see #253) this isn't a tmpfs right now.

comment:4 Changed 12 years ago by alphaone@…

  • Status changed from new to closed
  • Resolution set to fixed

/var is now mounted as tmpfs and Harald's workaround removed

Note: See TracTickets for help on using tickets.