Ticket #1522 (closed enhancement: fixed)

Opened 10 years ago

Last modified 15 months ago

Update packages

Reported by: wendy_hung Owned by: tick
Priority: high Milestone: Om2008.9
Component: Installer Version:
Severity: normal Keywords: must have
Cc: testing@…, zecke@…, marek@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Kernel : 20080621-asu.stable-uImage.bin
Root file system :20080623-asu.stable-rootfs.jffs2

Step:
1) launch assassin
2) click on UPDATE button
3) open any package
4) update package
5) no apparent difference in system

Question is: should we have all these packages within update?
Should only be updating packages that were installed through assassin.

Change History

comment:1 Changed 10 years ago by tick

  • Owner changed from tick@… to tick
  • Status changed from new to accepted

the condition is the same as 1521

comment:2 Changed 10 years ago by wendy_hung

Tick,

Go back and take a look at how the iPod installer does updating packages.
You can borrow mine if you want. Just let me know.

-Will

comment:3 Changed 10 years ago by tick

  • Status changed from accepted to closed
  • Resolution set to invalid
  • Milestone ASU deleted

I think it's not a issue.

Right now you will see a lot of updates, it because the ASU is still developing, and therefore the version upgrades very fast.

Yes, I think update shall shown all the updateable packages, because of in many cases bug happens in libraries, and in those cases there are no reason to upgrade applications.

This feature helps isolate problems.

comment:4 Changed 10 years ago by will

  • Status changed from closed to reopened
  • Cc testing@…, zecke@…, marek@… added; will@…, regina_kim@… removed
  • Resolution invalid deleted
  • Priority changed from normal to high
  • Milestone set to ASU
  • Keywords must have added
  • Type changed from defect to enhancement

As stated before.
At some point we need to be the one's maintaining our own software.
We should provide stable releases that we have tested and are known to be working releases.
A regular user will not be forgiving when he/or she decides to update some random package (that they do not understand) breaks Assassin or their system all together.
Tick, please try to understand why this is important.
If you need help realizing this, please just shout and we can find a way to work around this. Perhaps by asking for help from Holger, Marek, or even the community. We have expressed our will to having this feature.
Let me know how I can help.

comment:5 Changed 10 years ago by tick

  • Status changed from reopened to accepted

comment:6 Changed 10 years ago by tick

  • Status changed from accepted to in_testing

I think this had been solved. after opkg 4545

comment:7 Changed 10 years ago by will

very cool. should we use today 7/23 or tomorrow's 7/24 image to test?

comment:8 Changed 10 years ago by tick

7/23 you will find this issues had been solved, but there are still some other memory leak issues may crashes packagekitd
7/24 both of the issues are avoided or handled. (It will be more stable)

I will then try to deal with the memory leak one. (Finding out the root cause, and leaving the handling code there, in which does not hurt.)

comment:9 Changed 10 years ago by wendy_hung

Tested with the image below:

kernel:20080723-asu.stable-uImage.bin
root file system:20080730-asu.stable-rootfs.jffs2

the "UPDATE" without any packages now, i think it's ok now.
Should we close this ticket or keep it open?

comment:10 Changed 10 years ago by will

  • Milestone changed from Om2008.8 to Om2008.9

Test please.
12 days and not one package to upgrade?

comment:11 Changed 10 years ago by wendy_hung

  • Status changed from in_testing to assigned

tested with the image below in two devices:
kernel:20080808-asu.stable-uImage.bin
root file system:20080814-asu.stable-rootfs.jffs2

@68 showed up two packages in the "UPDATE", but none of them can download, show up the ERROR message update failed, reason "unknown"
@132,177, without any packages in UPDATE

Don't know if the package been took away or other reason, but show up unknown error message is also confusing....

comment:12 Changed 10 years ago by tick

  • Status changed from assigned to in_testing

Works for me.
Please test again.
If you can reproduce this, please come to me.
Let me find out. Thanks

comment:13 Changed 10 years ago by wendy_hung

tested with the image:
kernel:20080826-asu.stable-uImage.bin
root file system:20080901-asu.stable-rootfs.jffs2

Still can't test with this now, keep watching this and test later.

comment:14 Changed 10 years ago by wendy_hung

  • Status changed from in_testing to closed
  • Resolution set to fixed

use the old image to test it(8/29's rootfs), works!

about system update packages will open another ticket as #1950
:)

comment:15 Changed 19 months ago by RoberMync

Comprar Viagra Farmacia <a href=http://viag1.xyz/by-cheap-viagra.php>By Cheap Viagra</a> Sale Fedex Provera Low Price Acheter Kamagra Amiens <a href=http://cial5mg.xyz/cialis-online.php>Cialis Online</a> Online Pharmacy Thailand Sale Cialis Professional <a href=http://xenical.ccrpdc.com/where-to-buy-xenical.php>Where To Buy Xenical</a> Buy Cialis Brand Online Achat Viagra Pharmacie En Ligne <a href=http://kamagra.ccrpdc.com/kamagra-tablet.php>Kamagra Tablet</a> Propecia 20mg Online Order Diflucan No Prescription <a href=http://viag1.xyz/cheap-viagra-100mg.php>Cheap Viagra 100mg</a> Buy Cialis 10mg Uk Amitriptyline No Rx <a href=http://cial5mg.xyz/cheap-cialis-no-rx.php>Cheap Cialis No Rx</a> Medicamento Cialis 10 Quanto Costa Viagra <a href=http://zol1.xyz/buy-zoloft-cheap.php>Buy Zoloft Cheap</a> Pfizer Viagra Online Viagra Et Mode D'Emploi <a href=http://kama1.xyz/where-can-i-buy-kamagra.php>Where Can I Buy Kamagra</a> Provera Irregular Periods Website

comment:16 Changed 15 months ago by MiguAnydaY

Nolvadex Astrazeneca http://cialtobuy.com - cialis Levitra Vom Hausarzt
Preise Viagra 50
Levitra Orodispersibile Prezzo <a href=http://cialtobuy.com >viagra cialis</a> Is There A Way To Get Avanafil Cheaper

Note: See TracTickets for help on using tickets.