Ticket #1607 (closed defect: duplicate)

Opened 11 years ago

Last modified 11 years ago

TS misalignment when in landscape mode

Reported by: kenrestivo Owned by: openmoko-devel
Priority: highest Milestone:
Component: unknown Version: 2007.2
Severity: normal Keywords:
Cc: nomeata Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

If I execute "xrandr -o 1" and rotate the screen, then the keys along the right side of the keyboard are visible but inaccessible. Pressing them actually activates the keys to the left of them (i.e. 3, 6, 9, etc). All the keys are shifted to the left by one "square", and of course the keys are not square anymore, they are stretched rectangularly when in landscape mode.

This is in a stock FreeRunner? just out of the box. Doing the opkg update; opkg upgrade dance did not fix it.

Change History

comment:1 Changed 11 years ago by kenrestivo

I should note that the keys that don't work in landscape mode are the backspace, forwardspace, and return keys, thus the keyboard cannot be used in landscape mode.

The workaround I came up with was to type text in portrait mode, then flip the thing to landscape mode, then flip it back again, but that's somewhat unsatisfying.

comment:2 Changed 11 years ago by emilis.info

I can confirm this bug. Happened both with original image and with updates.

comment:3 Changed 11 years ago by nomeata

  • Cc nomeata added

comment:4 Changed 11 years ago by peepsalot

  • Status changed from new to closed
  • Resolution set to duplicate

This looks like a duplicate of bug #1244

Note: See TracTickets for help on using tickets.