Ticket #1615 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Busybox or Perl-Module-Cpan need a fix

Reported by: iandouglas736 Owned by: openmoko-kernel
Priority: normal Milestone:
Component: kernel Version:
Severity: normal Keywords: busybox gzip cpan
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Since gzip is a symlinked command to busybox, and not the full gzip utility, the perl-module-cpan library often fails to unpack tarballs because the CPAN module is configured to use a --decompress flag to gzip, when the busybox version of gzip only supports the shorter -d flag equivalent.

Either busybox needs to be changed to allow the full --decompress flag, or the perl-module-cpan package needs to be altered to use the shorter -d flag that *is* supported by the busybox gzip utility.

Change History

comment:1 Changed 11 years ago by mwester

A better solution would be to have the "gzip" package added to the feeds, so that "opkg install gzip" would make the full non-busybox version of gzip available.

Unfortunately it seems that the current feeds lack this utility, but rectifying that would probably be faster and more correct than modifying busybox or Perl modules.

comment:2 Changed 11 years ago by graeme

  • Status changed from new to closed
  • Resolution set to fixed

I have enabled gzip for the feeds so it should appear tonight. Thanks.

Note: See TracTickets for help on using tickets.