Ticket #1638 (closed enhancement: fixed)

Opened 11 years ago

Last modified 11 years ago

Replace current progress bar with asterisk progress wheel

Reported by: will Owned by: raster
Priority: high Milestone: Om2008.8
Component: E - Illume Version:
Severity: normal Keywords: must have
Cc: testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

We want to see the current progress bar used for launching applications to be replaced with a progress wheel in the center of the screen. Idea is to dim out background and rotate an asterisk.

Please see screenshot for details.

Attachments

progress_wheel.png (91.6 KB) - added by will 11 years ago.

Change History

Changed 11 years ago by will

comment:1 follow-up: ↓ 2 Changed 11 years ago by raster

simple version: can't do it. no compositing. (i can go into the technical nastiness of how it possibly can be done with a fair bit of work... but it would be a really ugly hack).

i need to repeat this:

NO TRANSLUCENCY POSSIBLE BETWEEN WINDOWS.

unless you want the wheel below application windows... and below the top bar. i can do it within the canvas.

please... august 8 is coming. don't add new things to do now. the current code pops up (slides in) a window at the bottom of the screen allowing the rest of the screen still to be used while it's busy. it's simple and works. if u want a different icon in that bar - ok.

either that or can you live with this being UNDER windows and UNDER the top-bar?

comment:2 in reply to: ↑ 1 Changed 11 years ago by will

Replying to raster:

NO TRANSLUCENCY POSSIBLE BETWEEN WINDOWS.

aren't we doing this when we boot / shut down?

please... august 8 is coming. don't add new things to do now. the current code pops up (slides in) a window at the bottom of the screen allowing the rest of the screen still to be used while it's busy. it's simple and works. if u want a different icon in that bar - ok.

either that or can you live with this being UNDER windows and UNDER the top-bar?

let me see what that looks like..
will get back on this.

comment:3 follow-up: ↓ 4 Changed 11 years ago by raster

when we boot and shut down we are not running X. no windowing system at all - no separate windows. its just exquisite writing the the dumb framebuffer device.

btw - a window is a specific entity in x - a "Rectangle" that you can draw to. the top shelf, the "starting app...x" and a bunch of things in E are windows. every application that runs opens a window. dialogs are windows. thats what you can't to translucency between. a window defines a boundary between the control of one thing and another of that part of the screen.

comment:4 in reply to: ↑ 3 Changed 11 years ago by will

Replying to raster:

btw - a window is a specific entity in x - a "Rectangle" that you can draw to. the top shelf, the "starting app...x" and a bunch of things in E are windows. every application that runs opens a window. dialogs are windows. thats what you can't to translucency between. a window defines a boundary between the control of one thing and another of that part of the screen.

Even if we are doing this under the window, there can not be transparency?

comment:5 Changed 11 years ago by raster

if u are happy with not having translucency over the top bar... or over other windows, then it can be done

comment:6 Changed 11 years ago by will

If we can get some transparency then its good :)
Let's do this under the top bar.

comment:7 Changed 11 years ago by raster

  • Status changed from new to in_testing

comment:8 Changed 11 years ago by wendy_hung

  • Status changed from in_testing to closed
  • Resolution set to fixed

Tested with the image below:

kernel:20080723-asu.stable-uImage.bin
root file system:20080731-asu.stable-rootfs.jffs2

it's the asterisk progress wheel now, thank you!!

Note: See TracTickets for help on using tickets.