Ticket #1641 (closed defect: fixed)

Opened 11 years ago

Last modified 10 years ago

opkg upgrade blows away custom volume settings

Reported by: hedora Owned by: Nytowl
Priority: normal Milestone: Om2009
Component: Distro Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

The *.state files used to control alsa profiles are stored in /usr, and get overwritten without prompting by opkg upgrade.

This is really irritating, since it makes my headphones really loud, and there's no way practical to change the volume back via the current phone UI. Worse, mediaplayer's volume setting doesn't go low enough to make the default settings usable with my headphones...

Shouldn't these be treated as configuration files (so they're not automatically reverted to default values), and be stored in /etc or ~?

Perhaps it could let people override the defaults by checking for a copy of each *.state file in ~/.openmoko or /etc/openmoko before applying the default state. Then a comment could be added to the files in /usr directing people to create / edit copies elsewhere.

Change History

comment:1 follow-up: ↓ 2 Changed 11 years ago by zecke

For now it is a nice way to make people send patches. Would you mind sharing your changed state files and describe what they fix?

comment:2 in reply to: ↑ 1 Changed 11 years ago by hedora

Sorry; lost track of this. I just set the headphone volume down a bit, and messed with the mixer settings. I don't want to send a patch, since the changes are specific to the headphones that I bought, and the noise levels during my commute.

comment:3 Changed 10 years ago by john_lee

  • Owner changed from openmoko-devel to julian_chu
  • HasPatchForReview unset
  • Component changed from unknown to Distro

we can make the alsa state files "CONFFILES" so opkg will ask the user if one wants to update them.

comment:4 Changed 10 years ago by roh

  • Owner changed from julian_chu to Nytowl

maintainer change

comment:5 Changed 10 years ago by Nytowl

  • Status changed from new to accepted

comment:6 Changed 10 years ago by Nytowl

  • Status changed from accepted to in_testing

comment:7 Changed 10 years ago by Nytowl

  • Status changed from in_testing to closed
  • Resolution set to fixed
  • Milestone set to Om2009
Note: See TracTickets for help on using tickets.