Ticket #1645 (closed defect: duplicate)

Opened 11 years ago

Last modified 11 years ago

Keys remapping when USB is connected

Reported by: Mercury Owned by: openmoko-devel
Priority: normal Milestone:
Component: unknown Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

I have a recent build on my freerunner, which I have modified according to the instructions under 'How do I install it?' on this wiki page 'http://www.openmoko.org/wiki/Switching_Keyboards'.

When I have a USB connection plugged in, some keys will be remapped improperly. For example, when I enter 0 it will come out as }, and when I try to enter a capital M it gives me a lower case m.

I don't believe this problem is related to me messing with matchbox-keyboard, however, because I have a bluetooth keyboard which I connect with hidd, and it displays the exact same behaviour.

Change History

comment:1 Changed 11 years ago by zecke

  • Status changed from new to closed
  • Resolution set to duplicate

This is a duplicate of #1533.

Note: See TracTickets for help on using tickets.