Ticket #1648 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

[efl] efreet libraries moved from libefreet0 to efreet making automatic upgrade impossible

Reported by: kenrestivo Owned by: tick
Priority: normal Milestone: Om2008.8
Component: Distro Version: GTA02v5
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Collected errors:

  • Package efreet wants to install file /usr/lib/libefreet.so.0.5.0

But that file is already provided by package * libefreet0

  • Package efreet wants to install file /usr/lib/libefreet.so.0

But that file is already provided by package * libefreet0

  • Package efreet wants to install file /usr/lib/libefreet.so.0.5.0

But that file is already provided by package * libefreet0

  • Package efreet wants to install file /usr/lib/libefreet.so.0

But that file is already provided by package * libefreet0

  • Package efreet wants to install file /usr/lib/libefreet.so.0.5.0

But that file is already provided by package * libefreet0

  • Package efreet wants to install file /usr/lib/libefreet.so.0

But that file is already provided by package * libefreet0

Change History

comment:1 Changed 11 years ago by zecke

  • Status changed from new to closed
  • Resolution set to invalid

Closing as invalid for now as upgrading is not yet a supported use case.

For the future please:

  • Do not assign people
  • Do not set milestones
  • Provide more information. From which version to which one did you try to upgrade? How far away are the builds? So /usr/lib/libefret.so.0 moved from libefreet0 to the efreet package?

comment:2 Changed 11 years ago by zecke

  • Status changed from closed to reopened
  • Component changed from opkg to Distro
  • Resolution invalid deleted
  • Summary changed from Opkg Upgrade fails to [efl] efreet libraries moved from libefreet0 to efreet making automatic upgrade impossible

Actually, reopening. So this from last efl update to the one I just did a couple of hours ago. Taking a look

comment:3 Changed 11 years ago by zecke

  • Status changed from reopened to closed
  • Resolution set to fixed

I pushed an update to org.openmoko.asu.dev. libefreet_trash was new and LEAD_SONAME was not set to the debian renaming of the package didn't kick in. I have set a LEAD_SONAME in the bb file now and split out libefreet_trash. You might get an app launch error due the missing libefreet_trash library but in this case we have to bump the PR of these packages.

Also left as an excercise is to go through the other efl library package and check if a LEAD_SONAME needs to be set.

thanks for reporting the issue.

comment:4 Changed 11 years ago by kenrestivo

Thanks for fixing it.

You guys are working incredibly quickly. Nice to see this progress so fast.

comment:5 Changed 11 years ago by Yorick

  • Status changed from closed to reopened
  • Resolution fixed deleted

I'm also getting these errors when doing an opkg upgrade:
Upgrading angstrom-version on root from 1:P1-Snapshot-20080726-r1 to 1:P1-Snapshot-20080727-r1...
Downloading http://downloads.openmoko.org/openmoko-repository/ASU/om-gta02/angstrom-version_P1-Snapshot-20080727-r1_om-gta02.ipk
Multiple replacers for atd, using first one (at-dbg)
Multiple replacers for atd, using first one (at-dbg)
Assuming locally installed package atd (0.70-r4) is up to date.
Upgrading e-wm on root from 0.16.999.042+cvs20080722-r10 to 0.16.999.042+cvs20080725-r11...
Downloading http://downloads.openmoko.org/openmoko-repository/ASU/armv4t/e-wm_0.16.999.042+cvs20080725-r11_armv4t.ipk
Installing libefreet0 (1:0.5.0.043+cvs20080610-r0) to root...
Downloading http://rabenfrost.net/celtune/ipk/armv4t/libefreet0_0.5.0.043+cvs20080610-r0_armv4t.ipk
Upgrading illume on root from 0.0+svnr152-r6 to 0.0+svnr167-r6...
Downloading http://downloads.openmoko.org/openmoko-repository/ASU/armv4t/illume_0.0+svnr167-r6_armv4t.ipk
Installing libefreet0 (1:0.5.0.043+cvs20080610-r0) to root...
Downloading http://rabenfrost.net/celtune/ipk/armv4t/libefreet0_0.5.0.043+cvs20080610-r0_armv4t.ipk
Configuring angstrom-version
Collected errors:

  • Package=atd, 2 matching providers
  • at-dbg
  • at-dbg
  • Please select one with opkg install or opkg flag prefer
  • Package libefreet0 wants to install file /usr/lib/libefreet.so.0.5.0

But that file is already provided by package * efreet

  • Package libefreet0 wants to install file /usr/lib/libefreet.so.0

But that file is already provided by package * efreet

  • Package libefreet0 wants to install file /usr/lib/libefreet.so.0.5.0

But that file is already provided by package * efreet

  • Package libefreet0 wants to install file /usr/lib/libefreet.so.0

But that file is already provided by package * efreet

comment:6 Changed 11 years ago by Yorick

some more info about the kernel i'm running:

root@om-gta02:~# opkg list_installed | grep kernel
kernel - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
kernel-2.6.24 - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
kernel-image-2.6.24 - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
kernel-module-arc4 - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
kernel-module-bluetooth - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-bnep - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-cifs - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-crc-ccitt - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
kernel-module-ecb - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
kernel-module-hci-usb - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-hidp - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-l2cap - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-michael-mic - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
kernel-module-nls-utf8 - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
kernel-module-ohci-hcd - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-ppp-async - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
kernel-module-ppp-deflate - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
kernel-module-ppp-generic - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
kernel-module-ppp-mppe - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
kernel-module-rfcomm - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-sco - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-scsi-mod - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
kernel-module-sd-mod - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
kernel-module-slhc - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
kernel-module-snd - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-snd-mixer-oss - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-snd-page-alloc - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-snd-pcm - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-snd-pcm-oss - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-snd-soc-core - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-snd-soc-neo1973-gta02-wm8753 - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-snd-soc-s3c24xx - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-snd-soc-s3c24xx-i2s - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-snd-soc-wm8753 - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-snd-timer - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-uinput - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
kernel-module-usb-storage - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
kernel-module-usbhid - 2:2.6.24+git24+be0f111b3d1570dec174ff301d08bad995ccf1e6-r0 -
kernel-module-usbserial - 2:2.6.24+git75929+66a83c97c4545ce4f07e0d90998f906fae49caf2-r1 -
task-base-kernel26 - 1.0-r69 -

comment:7 Changed 11 years ago by zecke

  • Status changed from reopened to closed
  • Resolution set to fixed

The initial bug is fixed. There is no efreet in the ASU feed we provide. For me it looks like you used -force-overwrite to get efreet overwrite libefreet0, to get back to normal you would probably have to do the same again. I have no idea which branch that community repository is building from and if it is compatible to org.openmoko.asu.stable and no idea from which image you started. Also the output in regard to atd looks weird, so it might not be wise to mix the two builds.

Anyway as the original issue is fixed I will close this bug again. If you think this is not the proper resolution please file a new bug with your issue but it will be tricky as you mix repositories. In future bug reports please include the information from which image you have started, what you have installed or changed to get there.

Note: See TracTickets for help on using tickets.