Ticket #1664 (closed enhancement: fixed)

Opened 11 years ago

Last modified 11 years ago

Use openresolv for resolv configuration

Reported by: candrews Owned by: raster
Priority: normal Milestone:
Component: Network Manager Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Ideally, DNS nameserver configuration should be transparent. The DHCP client should indicate the nameservers it has found, and the system uses them - and that's what openresolv does.

It looks like adding openresolv should be easy - it's posix shell and userland compliant, and well maintained.

Using resolv conf would make the instructions in http://wiki.openmoko.org/wiki/USB_Networking a little easier, and it would make wifi, bluetooth, and cellular networking feasible.

Change History

comment:1 Changed 11 years ago by candrews

BTW - the URL for openresolv is http://roy.marples.name/node/343

comment:2 Changed 11 years ago by raster

  • Status changed from new to closed
  • Resolution set to fixed

using resolvconf in ASU (connman needs it)... should mark this as invalid i guess :)

Note: See TracTickets for help on using tickets.