Ticket #1674 (closed defect: worksforme)

Opened 11 years ago

Last modified 19 months ago

Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_bluetooth.so

Reported by: montgoss Owned by: openmoko-devel
Priority: normal Milestone:
Component: unknown Version:
Severity: normal Keywords: bluetooth, pcm, alsa, a2dp
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

After pairing bluetooth headphones, an attempt to play sound generates the following error:
ALSA lib pcm.c:2106:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_bluetooth.so
aplay: main:546: audio open error: No such file or directory

My asound.conf contains:
pcm.!default {

type bluetooth
device "00:1A:45:1C:58:DE"

}
ctl.!default {

type bluetooth

}
pcm.bluetooth {

type bluetooth

}
ctl.bluetooth {

type bluetooth

}
# default dmix configuration
pcm.plug {

type plug
slave.pcm "dmix"

}
ctl.mixer0 {

type hw
card 0

}

Change History

comment:1 in reply to: ↑ description ; follow-up: ↓ 2 Changed 11 years ago by zecke

Replying to montgoss:

After pairing bluetooth headphones, an attempt to play sound generates the following error:
ALSA lib pcm.c:2106:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_bluetooth.so
aplay: main:546: audio open error: No such file or directory

is the above mentioned library installed at all?

comment:2 in reply to: ↑ 1 Changed 11 years ago by montgoss

Replying to zecke:

is the above mentioned library installed at all?

Exactly which library? alsa-lib 1.0.15-r0 is installed. I also installed kernel-module-snd-pcm. Made no difference.

comment:3 follow-up: ↓ 4 Changed 11 years ago by zecke

Well the summary says "Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_bluetooth.so". Is that file present?

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 5 Changed 11 years ago by montgoss

Replying to zecke:

Well the summary says "Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_bluetooth.so". Is that file present?

Nope. The only thing in the alsa-lib folder is a "smixer" folder.

comment:5 in reply to: ↑ 4 ; follow-up: ↓ 6 Changed 11 years ago by zecke

Replying to montgoss:

Replying to zecke:

Well the summary says "Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_bluetooth.so". Is that file present?

Nope. The only thing in the alsa-lib folder is a "smixer" folder.

Okay, from where did you get the asound.conf example? We have to make sure that we update the information... I think you will need to install bluez-utils-alsa.... but we might need to update the documentation?

comment:6 in reply to: ↑ 5 Changed 11 years ago by montgoss

Replying to zecke:

Okay, from where did you get the asound.conf example? We have to make sure that we update the information... I think you will need to install bluez-utils-alsa.... but we might need to update the documentation?

From the wiki of course: http://wiki.openmoko.org/wiki/Manually_using_Bluetooth#A2DP

And I don't see a bluez-utils-alsa. Where can I get that? It doesn't appear to be in the repository.

comment:7 Changed 11 years ago by Mercury

If/when you get this working, please see ticket #1656 and add a comment saying if you can reproduce the symptoms. I'm interested in seeing if other people can hear A2DP fine or not with a freerunner.

comment:8 Changed 11 years ago by zecke

  • Status changed from new to closed
  • Resolution set to worksforme

The documentation tells you to install bluez-utils-alsa, you didn't install it and alsa complains about a missing library that is provided by bluez-utils-alsa.

The bluez-utils-alsa package should show up in the ASU feed soon, for the other builds it is not in my control and feel free to file a separate bug.

comment:9 Changed 11 years ago by shashaness

I have also tried this I am running into an issue with signatures. The instructions are fodder of they do not work. I know there is a closed ticket saying that this has been fixed. But where? How? It simply says OM2008.8. Must I use an unstable version for this to work?

comment:10 Changed 11 years ago by shashaness

  • Status changed from closed to reopened
  • Resolution worksforme deleted

I do not know why this was closed.

I have the same issue. I followed the instruction on the wiki with both the original release of qTopia and 2007 (the latest builds) and it still does not work.

The required library is not there, obviously because of a missing package we need. I would love to test this, if I can get the package I need to make it work.

comment:11 follow-up: ↓ 12 Changed 11 years ago by zecke

  • Status changed from reopened to closed
  • Version GTA02v5 deleted
  • Resolution set to worksforme
  • Milestone Om2007.2 deleted

The reason I closed this bug is. The summary says a library can not be found, we identified that the library is not on the system (this explains why it can not be opened), we saw that the instructions do mention the installation of a package and this explains why the library is not present. If one is following the instructions (like installing a package) the setup is not going to fail at that point.

For OM2008.8 bluez-utils-alsa is in the feed and with my initial closing of the bug I encouraged to file separate bugs if the package is not available in the feed of your favored flavor (2007.2, FSO...).

comment:12 in reply to: ↑ 11 Changed 11 years ago by montgoss

Replying to zecke:

The reason I closed this bug is. The summary says a library can not be found, we identified that the library is not on the system (this explains why it can not be opened), we saw that the instructions do mention the installation of a package and this explains why the library is not present. If one is following the instructions (like installing a package) the setup is not going to fail at that point.

For OM2008.8 bluez-utils-alsa is in the feed and with my initial closing of the bug I encouraged to file separate bugs if the package is not available in the feed of your favored flavor (2007.2, FSO...).

Not to add fuel to the fire, but I did open a bug shortly after you closed this ticket. See #1683. You'll see that that bug was closed saying the package is available in Om2008.8, even though the summary specifically states that it's missing from the OM2007.2 repository.

Arne Anka was kinda enough to host an ipkg on his site: http://www.ginguppin.de/node/22
You can also build this yourself if you have MokoMakefile? working. I believe the command to run is:
make build-package-bluez-utils-alsa

comment:13 follow-up: ↓ 14 Changed 11 years ago by montgoss

Oh, and here's a link to the Om2008.8 repository which contains the needed ipk:
http://downloads.openmoko.org/repository/Om2008.8/armv4t/

comment:14 in reply to: ↑ 13 ; follow-up: ↓ 15 Changed 11 years ago by zecke

Replying to montgoss:

Oh, and here's a link to the Om2008.8 repository which contains the needed ipk:
http://downloads.openmoko.org/repository/Om2008.8/armv4t/

Only use that if you have a OM2008.8 image on your device as well. Please do not mix images and feeds as this is asking for problems.

comment:15 in reply to: ↑ 14 Changed 11 years ago by montgoss

Replying to zecke:

Replying to montgoss:

Oh, and here's a link to the Om2008.8 repository which contains the needed ipk:
http://downloads.openmoko.org/repository/Om2008.8/armv4t/

Only use that if you have a OM2008.8 image on your device as well. Please do not mix images and feeds as this is asking for problems.

Sorry. Guess I was confused since the resolution was that it existed in the Om2008.8 repository. :-P ;-)

comment:16 Changed 2 years ago by Kennescoma

All Day Chemist <a href=http://viag1.xyz/sildenafil.php>Sildenafil</a> Cialis Generico Da 5 Mg Buy Letrozole Gynecomastia <a href=http://kama1.xyz/low-cost-generic-kamagra.php>Low Cost Generic Kamagra</a> Levitra Servizio Sanitario Nazionale Propecia Donde Comprar Online <a href=http://cial5mg.xyz/cheap-cialis-tablets.php>Cheap Cialis Tablets</a> Isotretinoin Buy Online Uk Cialis No Prescription <a href=http://viag1.xyz/generic-viagra-100mg.php>Generic Viagra 100mg</a> Priligy Revenue Discount Card For Effexor Xr <a href=http://zol1.xyz/zoloft-online-prices.php>Zoloft Online Prices</a> Viagra Pills In Mexico No Prescription Needed International <a href=http://kama1.xyz/kamagra-online-fast.php>Kamagra Online Fast</a> Propecia Androgenos Zenegra 100 Buy From Usa <a href=http://cial1.xyz/generic-cialis-usa.php>Generic Cialis Usa</a> Cerco Viagra Generico Discount Cheap Amoxicilina <a href=http://viag1.xyz/viagra-price.php>Viagra Price</a> Brand Viagra Best Price Fluoxetine 40mg Eating Disorder Where To Order <a href=http://cial5mg.xyz/female-cialis.php>Female Cialis</a> Vente De Cialis France Can Keflex Cause High Blood Pressure <a href=http://zol1.xyz/buy-cheap-zoloft-on-line.php>Buy Cheap Zoloft On Line</a> Buy Wellbutrin 300 Xl Achat Tadalis Sx Homme <a href=http://nolvadex.ccrpdc.com/nolvadex-oral.php>Nolvadex Oral</a> Propecia Pharmacy Prices Buy Cialis 5mg Online Pharmacy <a href=http://kama1.xyz/where-to-order-kamagra.php>Where To Order Kamagra</a> Brand Viagra Free Shpping Baclofene Dose Seuil <a href=http://zol1.xyz/implicane.php>Implicane</a> Kamagra 100 Erfahrung Cheap Online Levitra <a href=http://zol1.xyz/zoloft-to-buy.php>Zoloft To Buy</a> Purchasing isotretinoin skin health medication Posologie Viagra 25mg <a href=http://zol1.xyz/buy-zoloft-online-usa.php>Buy Zoloft Online Usa</a> Feline Allergic Realtion To Amoxicillin Rulide <a href=http://zol1.xyz/zoloft-generic-name.php>Zoloft Generic Name</a> buy legit accutane Dove Acquistare Il Viagra Senza Ricetta <a href=http://viag1.xyz/canadian-viagra.php>Canadian Viagra</a> Viagra Fait Il Tenir Plus Longtemps Viagra Rezeptfrei Bestellen De <a href=http://viag1.xyz/generic-viagra-buy.php>Generic Viagra Buy</a> Real Levaquin Discount Low Price Online Viagra Super Force 100 Mg 60 Mg Pills <a href=http://kama1.xyz>Buy Kamagra</a> Cialis France Pharmacie

comment:17 Changed 20 months ago by RalphCleks

cialis generika versand aus europa

<a href="http://cialisxrm.com/">http://cialisxrm.com/</a>

cialis printable coupons

<a href=http://cialisxrm.com/>cialis pharmacie paris sans ordonnance
</a>

comment:18 Changed 19 months ago by Matthewderma

canadian drugs

<a href="http://canadianpharmacyrxbsl.com/">canadian pharmacy</a>

prescription drug price comparison

<a href=http://canadianpharmacyrxbsl.com/?tamoxifen-side-effects-in-women>tamoxifen side effects in women</a>
mexican online pharmacies
<a href="http://canadianpharmacyrxbsl.com/?inderalici">inderalici</a>

comment:19 Changed 19 months ago by FelipeBuh

trusted overseas pharmacies

<a href="http://canadianpharmacyrxbsl.com/">canadian online pharmacies</a>

prescription cost

<a href=http://canadianpharmacyrxbsl.com/?tadalafila-como-funciona>tadalafila como funciona</a>
buy drugs online
<a href="http://canadianpharmacyrxbsl.com/?amoxicillin-500mg-for-tooth-infection">amoxicillin 500mg for tooth infection</a>

comment:20 Changed 19 months ago by Matthewderma

canadian pharmacies shipping to usa

<a href="http://canadianpharmacyrxbsl.com/">canadian online pharmacies</a>

canadian pharmacy viagra

<a href=http://canadianpharmacyrxbsl.com/?viagra-pill>viagra pill</a>
legitimate online pharmacies
<a href="http://canadianpharmacyrxbsl.com/?otc-viagra">otc viagra</a>

Note: See TracTickets for help on using tickets.