Ticket #1679 (closed defect: invalid)

Opened 11 years ago

Last modified 11 years ago

"Timer expired" error when reading battery sys entries

Reported by: kriss Owned by: openmoko-kernel
Priority: normal Milestone:
Component: kernel Version: GTA02v6
Severity: normal Keywords: battery, kernel, sysfs
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Some of the entries in the battery sysfs directory are returning errors mesages when read.

Linux om-gta02 2.6.24 #1 PREEMPT Wed Jul 23 06:34:19 CEST 2008 armv4tl unknown

Example:

root@om-gta02:~# for i in /sys/devices/platform/bq27000-battery.0/power_supply/bat/*; do echo "==========================="; echo $i; cat $i; done
===========================
/sys/devices/platform/bq27000-battery.0/power_supply/bat/capacity
cat: read error: Timer expired
===========================
/sys/devices/platform/bq27000-battery.0/power_supply/bat/charge_full
cat: read error: Timer expired
===========================
/sys/devices/platform/bq27000-battery.0/power_supply/bat/current_now
cat: read error: Timer expired
===========================
/sys/devices/platform/bq27000-battery.0/power_supply/bat/device
cat: read error: Is a directory
===========================
/sys/devices/platform/bq27000-battery.0/power_supply/bat/online
1
===========================
/sys/devices/platform/bq27000-battery.0/power_supply/bat/power
cat: read error: Is a directory
===========================
/sys/devices/platform/bq27000-battery.0/power_supply/bat/present
0
===========================
/sys/devices/platform/bq27000-battery.0/power_supply/bat/status
Not charging
===========================
/sys/devices/platform/bq27000-battery.0/power_supply/bat/subsystem
cat: read error: Is a directory
===========================
/sys/devices/platform/bq27000-battery.0/power_supply/bat/technology
Li-ion
===========================
/sys/devices/platform/bq27000-battery.0/power_supply/bat/temp
cat: read error: Timer expired
===========================
/sys/devices/platform/bq27000-battery.0/power_supply/bat/time_to_empty_now
cat: read error: Timer expired
===========================
/sys/devices/platform/bq27000-battery.0/power_supply/bat/time_to_full_now
cat: read error: Timer expired
===========================
/sys/devices/platform/bq27000-battery.0/power_supply/bat/type
Battery
===========================
/sys/devices/platform/bq27000-battery.0/power_supply/bat/uevent
===========================
/sys/devices/platform/bq27000-battery.0/power_supply/bat/voltage_now
cat: read error: Timer expired
r

Change History

comment:1 Changed 11 years ago by andy

What kind of battery is in there at this time? It says Model: GTA02 or something else?

comment:2 Changed 11 years ago by kriss

It's a GTA01 Battery - rebooting with GTA02, be right back...

comment:3 Changed 11 years ago by kriss

Oh it's working with that battery! - Is there a way to also support the GTA01 Battery ID?

comment:4 Changed 11 years ago by andy

  • Status changed from new to closed
  • Resolution set to invalid

Nope, GTA02 battery has a nice monitoring chip we talk to in order to find out that stuff, GTA01 doesn't have anything like that. You can monitor voltage on the battery from another /sys node (although that monitoring is meant to be shaky at the moment), but that is quite hard to reliably relate to time until empty or time until full. So it's just something you can have with the shipping GTA02 battery.

Going to close as "invalid", since it is expected behaviour.

comment:5 Changed 11 years ago by kriss

Thanks for the quick response!

Note: See TracTickets for help on using tickets.