Ticket #1686 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

packagekit on org.openmoko.dev depends on newer opkg

Reported by: cesarb Owned by: julian_chu
Priority: normal Milestone:
Component: Distro Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

packagekit-0.2.3+git0+813fa8cfb139246cf180d52895b52b28616ae2f5-r9.03, which is the revision compiled by org.openmoko.dev, needs a recent revision of opkg because it calls opkg_repository_accessibility_check() on backends/opkg/pk-backend-opkg.c. That function was added on r4528, which is less than the r4558 found on conf/distro/include/sane-srcrevs.inc; however, there is a couple of lines in conf/distro/include/preferred-om-2008-versions.inc which override that and force the SRCREV of opkg to be 4488, thus making the packagekit compile fail.

The fix is simply to comment out both SRCREV lines at conf/distro/include/preferred-om-2008-versions.inc, letting the lines at sane-srcrevs.inc determine the revision to be used.

Change History

comment:1 Changed 11 years ago by queen6

Blah I should check bugzilla before fixing it myself. The solution was already there and would save a lot of time.

Confirmed bug and solution!

comment:2 Changed 11 years ago by graeme

  • Status changed from new to closed
  • Resolution set to fixed

Committed this fix, those lines were bogus. Thanks for the report.

Note: See TracTickets for help on using tickets.