Ticket #1697 (closed enhancement: fixed)

Opened 11 years ago

Last modified 10 years ago

[Battery] No Alert message when battery is low

Reported by: regina_kim Owned by: raster
Priority: high Milestone: Om2008.9
Component: E - Illume Version:
Severity: minor Keywords: pm
Cc: testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

kernel : 20080723-asu.stable-uImage.bin
rootfs : 20080730-asu.stable-rootfs.jffs2

summary : No Alert message when battery is low (icon shows empty battery)

step + current result : No Alert message when battery is low

expected result : it should show Alert message when batter is low.

Attachments

battery icons.zip (4.7 KB) - added by will 11 years ago.
pict7126.jpg (63.6 KB) - added by raster 10 years ago.
Red battery - there it is.

Change History

comment:1 Changed 11 years ago by zecke

  • Keywords pr added

Make sure this ends on will's list.

comment:2 Changed 11 years ago by zecke

  • Keywords pm added; pr removed

comment:3 Changed 11 years ago by wendy_hung

  • Priority changed from normal to high
  • Severity changed from normal to critical

comment:4 Changed 11 years ago by andy

  • Owner changed from openmoko-kernel to tick
  • Component changed from System Software to Assassin

Why is this assigned to kernel? Userspace has all kinds of monitoring of power already going on and needs to handle it.

comment:5 Changed 11 years ago by tick

  • Status changed from new to assigned
  • Owner changed from tick to raster
  • Component changed from Assassin to E - Illume

Hi Raster,

Would you let illume send out an alert message while the battery level is low?

Thanks
Tick

comment:6 Changed 11 years ago by andy

(Wah sorry tick, I looked through that list for something better to assign it to, didn't find anything and posted my question anyway with it randomly left on assassin. Thanks for correcting it)

comment:7 follow-up: ↓ 9 Changed 11 years ago by raster

  • Type changed from defect to enhancement
  • Severity changed from critical to minor

not for asu... :) e's battery meter can already do this - just its not configured to do it, nor is there any way to access the config to do this (as all means of accessing e's config have been removed by design from asu), and e's dialogs are not themed to match asu - still inherit default e theme... :)

comment:8 Changed 11 years ago by Sjors

The phone usually runs out of power when I am not watching it, so a few nasty beeps would be very helpful.

comment:9 in reply to: ↑ 7 Changed 11 years ago by will

  • Milestone changed from Om2008.8 to Om2008.9

Replying to raster:

not for asu... :) e's battery meter can already do this - just its not configured to do it, nor is there any way to access the config to do this (as all means of accessing e's config have been removed by design from asu), and e's dialogs are not themed to match asu - still inherit default e theme... :)

Raster, I'm not sure what this has to do with the the Config tool.
Can't we simply make the battery icon red when it reaches low levels?

comment:10 follow-up: ↓ 11 Changed 11 years ago by raster

ok - reason why "config" is involved:

the battery gadget is e's own default battery meter - the same one i see on my laptop. same code. exact same thng. it just has a different theme in illume (on ASU). that exact same code ALREADY can pop up a warning dialog if the battery reaches X percent or Y minutes left until empty. that code has been there for years now. that is configured to be DISABLED in ASU. there is a configuration dialog to enable/disable this and set the time or percentage at which to show it. the problem is that ASU is set up in such a way that the mechanism that has existed for years to do just this is not available to a user. so there is no need to "add" a dialog... it's already there! (in ASU it doesn't have a nice theme - but it would work... if you could turn it on). so to me this is a design issue as design wanted to be very particular about exactly what configuration is available and how. all the existing code E has had for years and infrastructure to expose this and make it accessible to users has been ignored, so i can't really do much. (the start of the whole exposure thing. must be in python etc. etc. i made a point of this but it was not my call) :)

i probably need to say "i told you so" in that life will just get harder and everything be more and more work the more design tries to fight against existing infrastructure and code. :(

anyway - as for battery going red - that is possible. it's just part of the theme. but as design is to be pixel perfect, until design specifies a red battery - i can't do it, as it's not specified in the design :(

comment:11 in reply to: ↑ 10 Changed 11 years ago by will

Replying to raster:

anyway - as for battery going red - that is possible. it's just part of the theme. but as design is to be pixel perfect, until design specifies a red battery - i can't do it, as it's not specified in the design :(

Will send you these files.

comment:12 Changed 11 years ago by raster

ok - no problems. if u just want a still red battery image - if u want it blinking or whatever... let me know.

Changed 11 years ago by will

comment:13 Changed 11 years ago by will

Ok, icon images attached.
Icon starts to turn red when there's one bar remaining.
Completely red when icon is empty.

comment:14 Changed 10 years ago by raster

  • Status changed from assigned to in_testing

this has been done for a while... :)

comment:15 Changed 10 years ago by regina_kim

kernel:20080827-asu.stable-uImage.bin
root:20080827-asu.stable-rootfs.jffs2

today's image still happen.

hey raster when can we get the fixed image ??

comment:16 Changed 10 years ago by raster

i assumed the battery going red was the simple solution/addressing of this?

comment:17 Changed 10 years ago by queen6

Well the very last thing you want to do to check if your battery is low, is to actually wake the phone up and check the illume icon.

The proper solution would include something you can see/hear without touching the phone.

1) making BEEP sound every now and than (every 2 min?)
2) blinking AUX led (every 30 sec?)

comment:18 Changed 10 years ago by regina_kim

  • Owner raster deleted
  • Status changed from in_testing to assigned

kernel : 20080826
rootfs : 20080902

what is the behavior of fixed ? still nothing happen.

comment:19 Changed 10 years ago by raster

  • Owner set to raster

i quote will from the above comments:

"Raster, I'm not sure what this has to do with the the Config tool.
Can't we simply make the battery icon red when it reaches low levels?"

this is done. i assumed this was the resolution and did just that, thus fixed/closed. no one has said "no we ALSO want the dialog too".

right now i'm busy with my own things though, so you'll have to live with this as the resolution or just turn on the dialog yourself - it is possible to do. look at the .src config files (mind you existing users won't get this turned on as they will have their old config, and there is no way to turn it on as the dialog to do this is not accessible unless you use the illume config panel, then it is). also the alert popup will not look so great as the gadman popup isnt styled and the popup contents isn't either.

comment:20 Changed 10 years ago by will

  • Status changed from assigned to in_testing

If the red battery is there then it's no problem. We just haven't seen that yet.
Is it not in stable yet?

comment:21 Changed 10 years ago by raster

oops - put in wrong bug report! not sure why! move here.

see jpeg (photo) i attached to the bug report above - and below. red battery is there. if testing/stable has it or not, i don't know, but below are the versions.

root@om-gta02:~# opkg list | grep illume
illume - 0.0+svnr35727-r13 -
illume-config-asu - 0.0+svnr35727-r13 -
illume-config-illume - 0.0+svnr35727-r13 -
illume-dicts-english-us - 0.0+svnr35727-r13 -
illume-keyboards-default - 0.0+svnr35727-r13 -
illume-keyboards-numbers - 0.0+svnr35727-r13 -
illume-keyboards-terminal - 0.0+svnr35727-r13 -
illume-theme - 0.0+svnr216-r5.04 -

Changed 10 years ago by raster

Red battery - there it is.

comment:22 Changed 10 years ago by regina_kim

thanks Raster.

but when can we get that image ???

today (20080903) still can not see red battery icon.

comment:23 Changed 10 years ago by raster

i have no idea. the way things (originally) worked was that work was done in asu.dev then moved to stable. then zecke had his own tree, and s testing branch was added etc. but zecke moved stuff from dev to stable/testing. so i don't know when you can get it - you'll have to ask john/julian/zecke. :)

comment:24 Changed 10 years ago by zecke

Should be in tomorrows stable build.

comment:25 Changed 10 years ago by regina_kim

  • Status changed from in_testing to closed
  • Resolution set to fixed

kernel : 20080903
rootfs : 20080904

it shows red battery icon.

comment:27 Changed 10 years ago by regina_kim

hey Queen6.

No "beep" is because illume bar does not support sound effect.
so maybe we will try next product.

thanks.

comment:28 Changed 10 years ago by queen6

Hey Regina,

Well maybe that's me, but I don't think illume has anything to do with this problem.

What we need is a power manager daemon which would monitor battery level and when it reaches critical level will inform user about it, with action defined by the user or turn off the phone when battery level reaches 2-3% to avoid dead battery problems. Action examples:

1) beep from speaker
2) blink of AUX led
3) playing WAV/OGG/MP3 sample (like - "Your battery level has reached 5%. It's highly recommended to connect your phone to the charger").
4) scriptable actions would be nice as well, as user can create whatever he wants here.

The idea is to know when phone is low on power WITHOUT touching it. How often do you turn on your current phone to check the level of your battery?

Also the notification should work when phone is suspended. I'm pretty sure beep, sound sample or script can't be achieved that way (would require bringing CPU up, executing action and instantly suspend the device without turning the screen on).
The led blinking should be possible without bringing CPU up, right?

Is ompower the right place for such actions?

Note: See TracTickets for help on using tickets.