Ticket #1775 (closed defect: duplicate)

Opened 11 years ago

Last modified 11 years ago

qpe on 2008.8 crashes on startup

Reported by: billk Owned by: openmoko-kernel
Priority: highest Milestone: Om2008.8
Component: kernel Version: Om2008.8
Severity: blocker Keywords: gsm qpe phone
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

the following line is present in "ps aux" as soon as I login

root 1413 0.0 0.4 2568 520 ? S 20:14
0:00 /usr/bin/app-restarter The qpe process vanished. This is ad.?This is not meant to happen and is likely a sig n of?a bug in Qtopia. Please try to reproduce it and?report the issue to http://docs.openmoko.org.??To be able to use your phone as a phone again you?will have to restart Qtopia.? qpe

The phone never registers with the network (does using 2007.2)
My attempts to manually restart qpe (type qpe in the terminal) end up with an unusable display.

Change History

comment:1 Changed 11 years ago by lock

i think that is a normal behaviour, becouse if you tray to kill qpe you got an alert which message exactly the same as in in the ps aux, and also if you type app-restarter --help you can see that, that is only a proces to keep running qpe and restarting it if it crash or fail.

but thre are problems which connecting to the GSM network. in my case i cloud recieve calls but i can't make a coll becouse of an alert (i can't remember the alert message and don't have om2008.8 on FR but i'll check it morning) ... and that is a poblem. tray icon (the one, left of battery icon) looks like phone is out of the range of GMS transmitter. i've tray which packages form dayli-feed repo and have same problems.

my friend has also the same problem (which connecting to GMS network) on Om2008.8 (we both leave in Poland in same city)

comment:2 Changed 11 years ago by billk

Not the same problem - I am not killing qpe - this message is there on startup!

I get no "alert message" - the phone just doesnt even register with the network. If I run qpe manually, it still doesnt register - just gives messages about a "Mux being unavailable". The display problem I had with qpe was because it needed backgrounding.

BillK

comment:3 Changed 11 years ago by Rorschach

No you missunderstand this. app-restarter is a process running the whole time which checks if qpe is running. If it's not, app-restarter shows the above string in an error-message and asks if it should restart qpe.

So seeing this process in ps aux is no bug, it's a feature ;)

Just check if qpe is running with: ps aux|grep qpe and you'll see it is there.

comment:4 Changed 11 years ago by regina_kim

  • Status changed from new to closed
  • Resolution set to duplicate

this ticket duplicted with #1691.

Note: See TracTickets for help on using tickets.