Ticket #1782 (closed defect: duplicate)

Opened 11 years ago

Last modified 11 years ago

Contacts decoding

Reported by: tobias Owned by: zecke
Priority: normal Milestone:
Component: Qtopia Version: Om2008.8
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

It looks like the contact-names aren't decoded in the right way.
i.e. Umlauts (ö, ä, ü) are not displayed. They are not replaced by some hieroglyphic sign like I know it from 2007.2 - they are just deleted out of the name.

Change History

comment:1 Changed 11 years ago by zecke

This is for SIM contacts?

comment:2 Changed 11 years ago by tobias

Exactly. i.e. the name «Bühlmann» becomes «Bhlmann».

comment:3 Changed 11 years ago by zecke

  • Owner changed from openmoko-kernel to zecke
  • Component changed from System Software to Qtopia

Qtopia does ask for the encoding of the modem (AT+CSCS?) but is never setting it. I have to take a look at what happens when we force unicode...(this means you can save less characters in the name...)

comment:4 Changed 11 years ago by zecke

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1941.

Note: See TracTickets for help on using tickets.