Ticket #1804 (closed enhancement: invalid)

Opened 11 years ago

Last modified 11 years ago

Menu items falsely activated during scrolling

Reported by: peepsalot Owned by: raster
Priority: lowest Milestone:
Component: E - Illume Version: Om2008.8
Severity: trivial Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

If you tap and drag a menu item, the menu scrolls as expected, but when released the menu item is sometimes activated. If the user is moving the menu significantly during a stroke, it should be assumed they are not trying to activate a menu item.

Note, this seems to only happen if you do not scroll past either end of the menu.(causing the stylus to move away from the initial menu item that the drag began on).
I noticed this mostly in the Settings menu, since it seems to currently be the longest menu(good for ample scrolling testing space).

I think the absolute value of the each menu movement should be accumulated, and if the total is past some small threshold(5px maybe?).

Examples test cases that should *not* activate menu item:
User scrolls 50 pixels down, not reaching the bottom
User scrolls 50 pixels up and 50 pixels down during a single drag. (net movement 0, but accumulated absolute value of movement = 100)

Example cases that *should* activate menu item:
User taps and does not scroll at all before releasing
User "scrolls" 1-5 pixels up or down (accidental slide during menu selection)

Change History

comment:1 Changed 11 years ago by raster

  • Status changed from new to closed
  • Priority changed from normal to lowest
  • Type changed from defect to enhancement
  • Resolution set to invalid
  • Severity changed from normal to trivial

the code HAS got code to detect "drag vs click". there is a simple threshold value - it just happens to be too low for your comfort. for mine i can say it is just fine. this code does exist - otherwise it would ALWAYS activate. it is ONLY a user preference. there is in fact a settings dialog for swizzling just that under finger scrolling. unfortunately for you it's at the maximum setting the gui allows, it's a simple matter of adding even more levels, but really - this isn't a defect or a bug. it is simply user preference. i think the default right now 24 pixels. there is a dialog in e to change this - but that dialog is disabled.

so as such - this isn't a matter for enhancement, any code changes or a bug.. it's simply user preference, and design decisions not to expose such config to the user (at which point i can't own such a bug as i don't make design decisions). if you wish to refile this as something else... go ahead. :) (just need to clarify what this is, and that it's not really a bug or an enhancement requirement as it's all already there - it's a config preference by design in ASU not exported to the user).

hope this helps. :)

Note: See TracTickets for help on using tickets.