Ticket #1816 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

om-locations-map-pack freezes the Freerunner

Reported by: avanc Owned by: olv
Priority: high Milestone: Om2008.9
Component: Locations Version: GTA02v5
Severity: blocker Keywords:
Cc: avanc, olv@…, jeremy@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

I tried to make a map package for Locations according to
Create offline maps
However, the FR freezes after I started om-locations-map-pack. I have to switch off the phone (pressing power button, no "Shuting down" message appears).
After reboot there is a .eet file with the size 0.

Change History

comment:1 Changed 11 years ago by zecke

  • Cc olv@…, jeremy@… added
  • Owner changed from openmoko-devel to marek
  • Component changed from unknown to Diversity

Diversity issue, cc'ing olv and jeremy.

comment:2 Changed 11 years ago by olv

  • Owner changed from marek to olv
  • Status changed from new to accepted
  • Priority changed from normal to high
  • Milestone changed from Om2008.8 to Om2008.9

om-locations-map-pack eats too much memory and takes down the whole machine. FR simply does not have enough horse power. A web version of map packager seems to be the solution.

Targeting Om2008.9.

comment:3 Changed 11 years ago by olv

It turns out packing map packages is too resource consuming to have a web version, without great efforts. I guess we should find a way around, until some new map format is decided and supported.

comment:4 Changed 11 years ago by olv

  • Status changed from accepted to closed
  • Resolution set to fixed

Ahh, wrong comment. It is solved as of 91f3bb445ba3d8b5042ed03e2d636389fc9cfe50, by forcing evas_object_free to be called.

Note: See TracTickets for help on using tickets.