Ticket #184 (closed defect: wontfix)

Opened 12 years ago

Last modified 12 years ago

openmoko-mainmenu should link against libmb

Reported by: koen@… Owned by: mickey@…
Priority: high Milestone:
Component: openmoko-mainmenu Version: current svn head
Severity: normal Keywords:
Cc: mickey@…, buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

building mainmenu errors out with unresolved symbols, the fix:


do_compile_prepend() {

sed -i -e 's:$(AM_LDFLAGS):$(AM_LDFLAGS)\ -lmb:' src/Makefile

}

That allowed it to build for me:
http://www.angstrom-distribution.org/repo/?action=details&pnm=openmoko-mainmenu

Change History

comment:1 Changed 12 years ago by mickey@…

openmoko-mainmenu needs to either a) link against libmb and remove all
copy'n'paste functions from libmb or b) NOT link against libmb and copy the
reminaing functions it uses as well.

I strongly recommend going the a) route. In the meantime, I "fixed" it by
linking against libmb to make it build in r1084.

comment:2 Changed 12 years ago by hrw@…

  • Cc mickey@… added

* Bug 151 has been marked as a duplicate of this bug. *

comment:3 Changed 12 years ago by stefan@…

  • Status changed from new to assigned

Mickey, to get it right: As you link it already now only removing the dead code
is needed to have this bug fixed completely?

Chen Jie, if mickey approves this, can you please remove the duplicated code,
test and commit to svn? Thanks.

comment:4 Changed 12 years ago by laforge@…

  • Status changed from assigned to new
  • Owner changed from cj_steven@… to mickey@…

reassigning to default owner, since cj_steven is no longer involved in this project

comment:5 Changed 12 years ago by alphaone@…

  • Status changed from new to closed
  • Resolution set to wontfix

Wont fix, as today replaces the main menu in OM-2007.2

Note: See TracTickets for help on using tickets.