Ticket #1863 (closed defect: invalid)

Opened 11 years ago

Last modified 11 years ago

illume-config package does not provide the spanner/wrench

Reported by: Yorick Owned by: raster
Priority: normal Milestone: Om2008.8
Component: E - Illume Version: GTA02v5
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible: always

Description

When installing illume-config on Om2008.8-update the qwerty button appears, but not the spanner.

Change History

comment:1 follow-up: ↓ 2 Changed 11 years ago by raster

  • Status changed from new to closed
  • Resolution set to invalid

the config in the updates removes the gadget as that is what was always requested by om's design department. the spanner was never meant to be available to the public and the whole config theme hack is just that - a nasty hack on top of a release of code that was not ready (an earlier release of illume was let out rather than the one i prepared), so you won't be getting the spanner back, UNLESS you literally rm -rf ~/.e/ and set up a new config of your own. right now asu.dev ships with 2 config profiles - asu and illume. illume will get you what you want - edit /etc/enlightenment/default_profile to change that (even this is a hack and i will eventually make this redundant - but i suspect ASU (2008.08) will keep using it. FSO should continue with the cleaner mechanism when i get to fixing it all up.

so as such - that spanner was not meant to be in the release and it's simply a back door hack that doesn't work anymore. so i will have to close this.

comment:2 in reply to: ↑ 1 Changed 11 years ago by Yorick

Replying to raster:

the config in the updates removes the gadget as that is what was always requested by om's design department. the spanner was never meant to be available to the public and the whole config theme hack is just that - a nasty hack on top of a release of code that was not ready (an earlier release of illume was let out rather than the one i prepared), so you won't be getting the spanner back, UNLESS you literally rm -rf ~/.e/ and set up a new config of your own. right now asu.dev ships with 2 config profiles - asu and illume. illume will get you what you want - edit /etc/enlightenment/default_profile to change that (even this is a hack and i will eventually make this redundant - but i suspect ASU (2008.08) will keep using it. FSO should continue with the cleaner mechanism when i get to fixing it all up.

so as such - that spanner was not meant to be in the release and it's simply a back door hack that doesn't work anymore. so i will have to close this.

hmmmm...
so they removed some functionallity withouth giving us a way to get that functionality back? What is the philosophy behind this?

And are you guys planning to add the double-click/top bar size/icon size/framerate... conrig to the the settings app?
If not: why not?
If yes: why not wait with removing the spanner till it is implemented somewhere else?

comment:3 Changed 11 years ago by raster

this kind of thing has been done to death on the community mailing list (see the ASU Terminal thread about the keyboard). OM's design department decide what you get in the default UI. they repeatedly complained about my spanner icon and the config panel i had in illume. it was kept until the end ONLY for my purposes of doing debugging and work then was to be removed. as ASU didn't use the updated illume packages i prepared for release, it was a theme hack that hide the icon - not the proper thing of just removing the gadget. the design department didn't want any config for all the other things - don't ask me why, but my job is to do what they want, and so that is what gets done. i made them unhappy enough before by disagreeing with their design decisions and doing something else. i will not do that anymore. i do exactly just what they ask. you have a hack available for yourself by changing to a different profile (which is liable to keep working). sorry - but i'm simply doing what om wants.

comment:4 Changed 11 years ago by Yorick

Than you Raster, I understand that you can't do anything about it.
I guess I'm just disappointed with the way OM design's department is handling the questions for clarification from the users...

comment:5 Changed 11 years ago by marek

  • Status changed from closed to reopened
  • Resolution invalid deleted

The Openmoko designers just wanted to have their "clean" default design and everything moved to packages (including the wrench). One of these designers created the illume-config package himself.

Is there no way to bring back the flexibility of moving this wrench to a package ? Why is that ?

comment:6 Changed 11 years ago by raster

  • Status changed from reopened to closed
  • Resolution set to invalid

it's not possible. the wrench is part of a list of gadgets to show - that list is held in the users config - as that list is re-using e's internal gadget infrastructure to allow users to add/remove gadgets that either e or modules etc. provide. ASU simply covered it up by hacking a theme - theme shouldn't determine the contents of your gadgets - it just determines look. so this is the pain needed to go through thanks to the way ASU was released - ie with the wrench gadget still configured to be there but just covered up in theme.

this basically is a result of the narrow view that all config is to be done by packages. e's code simply doesn't work that way. packages can provide extra modules that a user then may or may not enable - modules can provide more gadgets that a user may or may not want to enable in a certain location (gadgets can live in many different places).

e is designed to work on a multi-user system where just the installation of a module on the system doesn't suddenly force every user to have it loaded. it's opt-in. just because something is installed does not mean it has to be used and "run". the "must install/uninstall packages to enable/disable gadgets and features" simply breaks the multi-user model, breaks the ability to have multiple profiles and breaks the ability to determine what gadgets would go where (as opposed to having them go in 1 and 1 place only and always be there if the module is installed - the wrench is part of illume as such as e's infrastructure allows a module to provide multiple gadgets, not just one - in fact any code can advertise a gadget class).

the way to flip configuration is via possibly installing new config PROFILES then telling e to use those. if a user already has such a profile their personal one always takes preference. installing a theme to do a makeup job to hide something is guaranteed to break as it's a hack to start with. see my first comment :)

comment:7 Changed 11 years ago by flamma

Isn't there a way to call the configuration application from the terminal?

comment:8 Changed 11 years ago by raster

no :( e was designed so it always had a gui way to rescue you. if you can change it in the gui. but e for asu has basically had that bit removed. the problem is the config panel is not a core e function - it is a function that is provided by a module - illume provides a replacement for the default e one. so i could add it - but it really is not intended to work that way. check in fso space for updates/changes here (think of it this way - if you removed the preferences menu from gimp... in a .rc file - and then wondered why u couldnt access the preferences option to re-enable it in the gui? :) u can get it back - u just have to fille with configs. config are binary - they can be decompiled to text and recompiled (eet the tool does that), but its easier just to have a set of system profiels that expose these and flip to them).

Note: See TracTickets for help on using tickets.