Ticket #1875 (closed enhancement: duplicate)

Opened 10 years ago

Last modified 10 years ago

Phone keeps on waking up (suspend (wait few seconds or minutes) => wakeup (wait 10s)=> suspend)

Reported by: octavsly Owned by: zecke
Priority: normal Milestone:
Component: Qtopia Version: Om2008.8
Severity: normal Keywords: suspend wakeup battery consumption
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible: sometimes

Description

The phone goes to suspend but keeps on waking up every now and then. Can it be because of loosing the GSM signal?

I am using the lastest kernel from http://downloads.openmoko.org/releases/Om2008.8-update/

and the latest qtopia*opk from:
http://downloads.openmoko.org/repository/Om2008.8/om-gta02/?C=M;O=D

Best regards,
Octavian

P.S.
I had the same behavior with a qtopia image.

Attachments

logread_1875.txt.gz (14.9 KB) - added by octavsly 10 years ago.
logread for phone waking up behaviour

Change History

comment:1 Changed 10 years ago by zecke

  • Milestone Om2008.8 deleted

The output of logread after it woke up would be of interest to me.

comment:2 Changed 10 years ago by octavsly

OK. I will try to get one as soon as I see the same behavior.

comment:3 Changed 10 years ago by octavsly

Did not see this behavior again. It was probably due to poor GSM signal.

Maybe an enhancement can be done:

  • many (3) GSM signal loses => disable wake-up, in case of GSM signal loss, for 30min/60min => re-enable wake up at signal loss

Something like some car alarms have when a sensor is activated too many times.

comment:4 Changed 10 years ago by octavsly

Just had the same behavior. I have increased the log buffer 10 times (/etc/syslog.conf) and I was able to get the log of the resume. Here is the important part (mind the time stamp jump from 9:26 to 9.30:

It appears like it tries to suspend then it wakes up

Sep 10 09:26:31 om-gta02 user.notice root: AtChat :  F : "+CMS ERROR: 512"
Sep 10 09:26:31 om-gta02 user.notice root: AtChat :  T : "AT+CMEE=1"
Sep 10 09:26:31 om-gta02 user.notice root: AtChat :  F : "+CMS ERROR: 512"
Sep 10 09:26:31 om-gta02 user.notice root: AtChat :  T : "AT+CFUN=1"
Sep 10 09:26:31 om-gta02 user.notice root: PowerManagement :  Acking suspend
Sep 10 09:26:31 om-gta02 daemon.notice apmd[1303]: Suspending now
Sep 10 09:26:31 om-gta02 user.warn kernel: [ 5440.615000] Syncing filesystems ... done.
Sep 10 09:26:31 om-gta02 user.debug kernel: [ 5440.615000] PM: Preparing system for mem sleep
Sep 10 09:30:27 om-gta02 user.warn kernel: [ 5440.905000] Freezing user space processes ...
Sep 10 09:30:27 om-gta02 user.notice root: PowerManagement :  Acked suspend 0
Sep 10 09:30:27 om-gta02 user.notice root: PowerManagement :  APM Event 3
Sep 10 09:30:27 om-gta02 user.notice root: PowerManagement :  Resume event
Sep 10 09:30:27 om-gta02 user.notice root: AtChat :  F : "+CMS ERROR: 512"
Sep 10 09:30:27 om-gta02 user.notice root: AtChat :  T : "^Z"
Sep 10 09:30:27 om-gta02 user.notice root: AtChat :  W : ""
Sep 10 09:30:27 om-gta02 user.notice root: AtChat :  W : "%CSQ:  8, 99, 0"
Sep 10 09:30:27 om-gta02 user.notice root: AtChat :  W : ""
Sep 10 09:30:27 om-gta02 user.notice root: AtChat :  W : "+CIEV: 1, 1"
Sep 10 09:30:27 om-gta02 user.notice root: Modem :  void CellModemManager::retryRfLevelRequest()


The complete logread is attached.

Changed 10 years ago by octavsly

logread for phone waking up behaviour

comment:5 Changed 10 years ago by zecke

  • Status changed from new to closed
  • Resolution set to duplicate

According to your log we get +CME ERROR 512 which indicates some sort of modem crash. Please see #1192 and recent versions of Openmoko Qtopia have code to detect that situation and inform the user.

Note: See TracTickets for help on using tickets.