Ticket #1957 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Installer is complaining about libopk, if there is no internet

Reported by: dolfje Owned by: tick
Priority: normal Milestone:
Component: Installer Version:
Severity: blocker Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

If I don't have internet and I want to start installer, it says 'Cannot initial installer. Please make sure they are only one processing using libopk, then restart Installer'. After you clicked that away, you get an Application Execution Error and I have attached the output.

Reproducible: always
kernel: om2008.8 update, date: 20080826
root: om2008.8 update, date 20080830 with updates of 04/09/08 (today)

Attachments

INSTALLER.log (142 bytes) - added by dolfje 10 years ago.

Change History

Changed 10 years ago by dolfje

comment:1 Changed 10 years ago by zecke

  • Owner changed from openmoko-devel to tick
  • Component changed from unknown to Installer

Tick have fun.

comment:2 Changed 10 years ago by tick

  • Status changed from new to accepted
  • Severity changed from normal to blocker

Oh~ My Bad.
I will deal with this.

comment:3 Changed 10 years ago by tick

  • Status changed from accepted to in_testing

This issue should be solved after assassin svn 233.

This issues is because assassin didn't distinguish different error type.
However, packagekitd shall not send out error message here.

However, I think it's a dirty hack. The root cause is packagekitd shall not send error message to assassin.
I am going to push some code back to packagekit upstream, at that mean while I will solve the root cause.

leave a FIXME in Assassin, to remind I myself remove the dirty hack.

comment:4 Changed 10 years ago by tick

  • Status changed from in_testing to closed
  • Resolution set to fixed

comment:5 Changed 10 years ago by tick

close it for it had been put in_testing for a long time, and no one complains about this.
It works for me.

Note: See TracTickets for help on using tickets.