Ticket #1968 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

MokoMakefile installed in dir with not trivial path does not work

Reported by: lman.dev Owned by: rod@…
Priority: low Milestone:
Component: host utilities Version:
Severity: minor Keywords: MokoMafileke
Cc: lman.dev Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible: always

Description

I've installed MokoMakefile? in dir ~/OpenMoko?/env-2008.08. Now when I'm traying to run

make openmoko-qtopia-x11-image

I get fallowing error

( cd build && . ../setup-env && \
          ( bitbake openmoko-qtopia-x11-image u-boot-openmoko ) )
ERROR: Unable to open conf/bitbake.conf
make: *** [openmoko-qtopia-x11-image] Error 1

When I move it to dir with simple name e.g. ~/OpenMoko?/env it works ok.

Change History

comment:1 Changed 10 years ago by zecke

  • Did you follow http://wiki.openmoko.org/wiki/MokoMakefile? I assume you missed make setup and make setup-machine-freerunner.
  • And the support mailinglist or the #openmoko irc channel might be better places for such kind of issues.

comment:2 follow-up: ↓ 3 Changed 10 years ago by lman.dev

Did you follow http://wiki.openmoko.org/wiki/MokoMakefile? I assume you missed make setup and make setup-machine-freerunner.

Yes, see the results:

~/env-2008.08 $ make setup
( [ -e stamps/bitbake ] && \
          [ -e bitbake/.git ] ) || \
        ( git clone -n git://git.openmoko.org/git/bitbake.git bitbake )
( cd bitbake && \
          ( git branch | egrep -e ' bitbake-om$' > /dev/null || \
            git checkout -b bitbake-om --track origin/bitbake-om ))
( cd bitbake && git checkout bitbake-om )
Already on "bitbake-om"
[ -d stamps ] || mkdir stamps
touch stamps/bitbake
( [ -e stamps/openembedded ] && \
          [ -e openembedded/.git ] ) || \
        ( git clone -n git://git.openmoko.org/git/openmoko.git openembedded )
( cd openembedded && \
          ( git branch | egrep -e ' org.openmoko.asu.stable$' > /dev/null || \
            git checkout -b org.openmoko.asu.stable --track origin/org.openmoko.asu.stable ))
( cd openembedded && git checkout org.openmoko.asu.stable )
Already on "org.openmoko.asu.stable"
[ -d stamps ] || mkdir stamps
touch stamps/openembedded
[ -e openmoko ] || ( mkdir openmoko )
[ -e stamps/openmoko ] || [ -e openmoko/trunk/.svn/entries ] || \
        ( cd openmoko && svn co http://svn.openmoko.org/trunk )
[ -e stamps/openmoko ] || [ -e openmoko/developers/.svn/entries ] || \
        ( cd openmoko && svn co http://svn.openmoko.org/developers )
[ -d stamps ] || mkdir stamps
touch stamps/openmoko
mkdir -p build/conf
[ -e build/conf/local.conf ] || \
        ( echo 'MACHINE = "om-gta01"' > build/conf/local.conf ; \
          echo 'DISTRO = "openmoko"' >> build/conf/local.conf ; \
          echo 'BUILD_ARCH = "'`uname -m`'"' >> build/conf/local.conf ; \
          echo 'INHERIT += "rm_work"' >> build/conf/local.conf )
rm -f build/conf/site.conf
( ln -sfn ../../openmoko/trunk/src/host/openembedded/site.conf build/conf/site.conf )
~/env-2008.08 $ make setup-machine-freerunner
mkdir -p build/conf
[ -e build/conf/local.conf ] || \
        ( echo 'MACHINE = "om-gta01"' > build/conf/local.conf ; \
          echo 'DISTRO = "openmoko"' >> build/conf/local.conf ; \
          echo 'BUILD_ARCH = "'`uname -m`'"' >> build/conf/local.conf ; \
          echo 'INHERIT += "rm_work"' >> build/conf/local.conf )
rm -f build/conf/site.conf
( ln -sfn ../../openmoko/trunk/src/host/openembedded/site.conf build/conf/site.conf )
( grep "MACHINE = \"om-gta02\"" build/conf/local.conf > /dev/null ) || \
        sed -i -e 's/^MACHINE[[:space:]]*=[[:space:]]*\".*\"/MACHINE = \"om-gta02\"/' \
                build/conf/local.conf
~/env-2008.08 $ make openmoko-qtopia-x11-image
( cd build && . ../setup-env && \
          ( bitbake openmoko-qtopia-x11-image u-boot-openmoko ) )
'''ERROR: Unable to open conf/bitbake.conf
make: *** [openmoko-qtopia-x11-image] Error 1'''
~/env-2008.08 $

And the support mailinglist or the #openmoko irc channel might be better places for such kind of issues.

Why? Isn't this site a bug report system for OpenMoko?? And isn't it a bug in image build system?

comment:3 in reply to: ↑ 2 Changed 10 years ago by zecke

Replying to lman.dev:

And the support mailinglist or the #openmoko irc channel might be better places for such kind of issues.

Why? Isn't this site a bug report system for OpenMoko?? And isn't it a bug in image build system?

Yes this is a bug report system for Openmoko. All I says is you will get better and faster help on irc or the support mailinglist for such kind of issues.

Next round of questions:

  • What did you set as OM_GIT_BRANCH? org.openmoko.asu.dev, org.openmoko.asu.testing are no more.

comment:4 Changed 10 years ago by lman.dev

OM_GIT_BRANCH := org.openmoko.asu.stable

comment:5 Changed 10 years ago by zecke

Do you have an openembedded/conf/bitbake.conf?

comment:6 Changed 10 years ago by lman.dev

Yes, I have.

comment:7 Changed 10 years ago by zecke

Time to attach setup-env. If the file exists BBPATH is wrong... which well is setup by the MokoMakefile?...

comment:8 Changed 10 years ago by lman.dev

OK, I found where the problem is. It's because I move dir with env to new location. The dir name is not a problem. The problem is that "make setup" does not update all needed file to point new location e.g OMDIR in setup-env is not updated.

comment:9 Changed 10 years ago by zecke

  • Status changed from new to assigned
  • Owner changed from openmoko-devel to rod@…

Okay, so a possible MokoMakefile? issue that it does not detect when the dir has been moved. Assigning this to Rod so he can decide if he wants to detect this or not.

comment:10 Changed 10 years ago by rwhitby

After moving the MokoMakefile? directory, did you:

make clobber
make setup

?

If you missed the make clobber step, then there will be setup files with the old path in them, which could cause bitbake to not be able to find the .conf file.

comment:11 Changed 10 years ago by rwhitby

  • Status changed from assigned to closed
  • Resolution set to fixed

Wiki page updated with warning not to move the directory:

http://wiki.openmoko.org/index.php?title=MokoMakefile&diff=52635&oldid=52565

Note: See TracTickets for help on using tickets.