Ticket #2021 (closed defect: fixed)

Opened 10 years ago

Last modified 17 months ago

/etc/init.d/dropbear restart doesn't work

Reported by: alih Owned by: julian_chu
Priority: normal Milestone:
Component: Distro Version: Om2008.9-dev
Severity: blocker Keywords: dropbear restart, HasPatch
Cc: mezhirov@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

"/etc/init.d/dropbear restart" doesn't kill dropbear. That's because dropbear is only a symlink.

Fix (I'll try to attach a patch): in /etc/init.d/dropbear replace DAEMON=/usr/sbin/dropbear with DAEMON=/usr/sbin/dropbearmulti.

Running 2008.9.20 snapshot of Om 2008.

Attachments

dropbear-patch (242 bytes) - added by alih 10 years ago.

Change History

Changed 10 years ago by alih

comment:1 Changed 10 years ago by alih

no, my patch doesn't work - it can't start it then. "dropbearmulti" should be used only when stopping.

comment:2 follow-up: ↓ 4 Changed 10 years ago by zecke

  • Keywords restart, HasPatch added; restart removed

Plese see http://wiki.openmoko.org/wiki/Bug_Filing_Policy. Specially when you have a patch please add HasPatch? to the keywords otherwise we will not see your patch. Trac does not send mails when something is attached, and there is no way to query for attachments.

comment:3 Changed 10 years ago by zecke

  • Owner changed from openmoko-devel to julian_chu
  • Component changed from unknown to Distro

Assigning it to the distro.

comment:4 in reply to: ↑ 2 ; follow-up: ↓ 5 Changed 10 years ago by Treviño

Replying to zecke:

Plese see http://wiki.openmoko.org/wiki/Bug_Filing_Policy. Specially when you have a patch please add HasPatch? to the keywords otherwise we will not see your patch. Trac does not send mails when something is attached, and there is no way to query for attachments.

Sorry if I'm completely OT with the bug reporting, but I'm replying to the HasPatch? thing: how can we set these tags when putting in a patch after that a bug has already been reported? I don't see any editable field here to modify the tags!
I figure it should be added; we, users, have too few permissions in trac!

comment:5 in reply to: ↑ 4 Changed 10 years ago by zecke

Replying to Treviño:

Sorry if I'm completely OT with the bug reporting, but I'm replying to the HasPatch? thing: how can we set these tags when putting in a patch after that a bug has already been reported? I don't see any editable field here to modify the tags!
I figure it should be added; we, users, have too few permissions in trac!

Hehe. For many being able to set a component is... We have different groups and there is no reason to not give externals the same rights as internals. Talking about HasPatch? and keywords you should be able to add it. In regard to your question there will be a custom boolean field HasPatch? soon(tm) you could check if there is a ticket at the admin trac and if not file one. :)

comment:6 Changed 10 years ago by julian_chu

I cannot reproduce this ticket.
The Restart is just calling stop+start.
Both of them works for me.

$ps ax |grep dropbear |grep -v grep

2242 ? Ss 0:00 /usr/sbin/dropbear -r /etc/dropbear/dropbear_rsa_host_key -p 192.168.0.202:22

$/etc/init.d/dropbear restart
Restarting Dropbear SSH server: stopped /usr/sbin/dropbear (pid 2242)
dropbear.
$ps ax |grep dropbear |grep -v grep

2276 ? Ss 0:00 /usr/sbin/dropbear -r /etc/dropbear/dropbear_rsa_host_key -p 192.168.0.202:22

comment:7 Changed 10 years ago by alih

Huh, that's weird. For me, stop leads to start-stop-daemon and doesn't work:

root@om-gta02:~# start-stop-daemon -K -x dropbear
no dropbear found; none killed

That's because of this:

root@om-gta02:~# ls -lh /proc/1279/exe
lrwxrwxrwx 1 root root 0 Sep 23 00:14 /proc/1279/exe -> /usr/sbin/dropbearmulti

Busybox searches for dropbear in /proc/*/exe, but there's only dropbearmulti.

Am I right to assume that if I have the latest daily snapshot of Om2008.8, I can count it as Om2008.9? (because I didn't reflash to Om2008.9)

Are you running the commands on an actual device? I'm asking because it should have thrown your shell out upon stopping dropbear.

comment:8 Changed 10 years ago by julian_chu

  • Status changed from new to in_testing

Hi Alih,

I always test by my own phone :-) (You can install terminal or use screen to avoid thrown by restart dropbear)

I found that why can't I reproduced the error, I use the testing repository and it use busybox-1.11.1, Om2008.9 use busybox-1.9.1.

this problem was solved in 1.11.1 (it search /proc/<pid>/cmdline but not /proc/<pid>/exe). therefore I think it was in testing but not enter stable repository yet.

comment:9 Changed 10 years ago by julian_chu

  • Status changed from in_testing to closed
  • Resolution set to fixed

comment:10 Changed 21 months ago by Chassmetly

Comprar Cialis Valencia Sin Receta <a href=http://kama1.xyz/kamagra.php>Kamagra</a> Accutane Buy Online Canada Orlistat Used <a href=http://kamagra.ccrpdc.com/buy-cheap-generic-kamagra.php>Buy Cheap Generic Kamagra</a> Viagra 100 Mg Costo Costo Levitra In Italia <a href=http://viag1.xyz/internet-order-viagra.php>Internet Order Viagra</a> Cialis 20mg Price At Walmart Albuterol Without Script <a href=http://kama1.xyz/kamagra-jellies.php>Kamagra Jellies</a> Rx Drug Sotre Mertropoltartatewithoutperscription <a href=http://kama1.xyz/low-cost-generic-kamagra.php>Low Cost Generic Kamagra</a> Overnight Viagra Mn No Prescription Kamagra Oral Jelly Wirkung <a href=http://kama1.xyz/kamagra-jelly-online.php>Kamagra Jelly Online</a> Celecoxib 200 Mg Price Prix Du Xenical En Belgique <a href=http://kama1.xyz/generic-kamagra.php>Generic Kamagra</a> Propecia After 1 Month 1mg Cheap Alternative To Effexor <a href=http://cial1.xyz/cialis-online-prices.php>Cialis Online Prices</a> Cialis Canada Free Sample Clomid 120g <a href=http://cial5mg.xyz/cialis-tadalafil.php>Cialis Tadalafil</a> Priligy Spray Asa And Cephalexin <a href=http://cial1.xyz/tadalafil-tablets.php>Tadalafil Tablets</a> Online Pharmacy Usa Prozac Propecia Dati Tecnici <a href=http://cial1.xyz/cialis-pills.php>Cialis Pills</a> Mifegyne En Ligne Cytotec5mg <a href=http://zol1.xyz/zoloft-buy-online.php>Zoloft Buy Online</a> Levitra 20 Mg Orosolubile Price For A 100 Mg Viagra <a href=http://cial1.xyz/best-cialis-online.php>Best Cialis Online</a> Comprar Cialis Malaga Real Generic Dutasteride Online <a href=http://accutane.ccrpdc.com/claravis.php>Claravis</a> Cheap Levitra Canadian Pharmacy Cialis 10 Mg Dosis <a href=http://zol1.xyz/cheap-generic-zoloft.php>Cheap Generic Zoloft</a> Viagra Generique Au Maroc Apply Keflex <a href=http://viag1.xyz/cheap-viagra-tablets.php>Cheap Viagra Tablets</a> Cealis 30 Tablet Trial Vendita Kamagra 150mg <a href=http://zol1.xyz/buy-cheap-zoloft-on-line.php>Buy Cheap Zoloft On Line</a> Vente Cialis En Belgique Sildenafil Ligne <a href=http://zol1.xyz/zoloft-online-pharmacy.php>Zoloft Online Pharmacy</a> Viagra Rischio Infarto Prix Du Viagra Suisse <a href=http://kama1.xyz/buy-kamagra-gel.php>Buy Kamagra Gel</a> Amoxicillin Joint Pain Cialis Wirkt Nicht Tun <a href=http://prednisone.ccrpdc.com/buy-generic-prednisone.php>Buy Generic Prednisone</a> Buy Tadalafil Online Online Drugstore Usa.C <a href=http://cial5mg.xyz/cialis.php>Cialis</a> Order Female Viagra Generic Doxycycline Skin <a href=http://cial1.xyz/online-cialis.php>Online Cialis</a> Levitra Per Quanto Tempo Buy Calais Sex Tablet <a href=http://viag1.xyz/viagra-sample.php>Viagra Sample</a> Keflex Without A Percrition Buy Amoxicillin Online Uk <a href=http://cial1.xyz/buy-cheap-cialis.php>Buy Cheap Cialis</a> Levitra Ohne Rezept Preisvergleich Smalloans. <a href=http://fastmoney-25.com>short term loans</a> If you are not our customer Individuals last decision on awarding the benefit Temporary disability to work or accidental death Poyczka z Gwarancj Najniszego Oprocentowania regulations in Polish link opens in new window Cash Loan Are you transferring your salary to Bank Millennium We encourage you to install the latest version of one of the popular browsers.Levitra Feminin <a href=http://viag1.xyz/biuy-viagra-online.php>Biuy Viagra Online</a> How To Find Orlistat 120 Mg 93551 Zip Hydrochlorothiazide Cheapeast El Paso <a href=http://cial1.xyz/cialis-to-buy.php>Cialis To Buy</a> Keflex Is Used For Mexican Pharmacies Shipping To Usa <a href=http://zol1.xyz>Buy Zoloft</a> Buy Elavil No Prescription Donde Puedo Comprar Lexapro En Canada <a href=http://viag1.xyz/cheap-viagra-25mg.php>Cheap Viagra 25mg</a> Acquistare Cialis Generico

comment:11 Changed 18 months ago by RalphCleks

cialis 5 mg per day

<a href="http://cialisxrm.com/">buy cialis online</a>

does cialis show up on drug tests

<a href=http://cialisxrm.com/>cialis without a doctor prescription</a>

comment:12 Changed 17 months ago by Matthewderma

online pharmacies no prescription

<a href="http://canadianpharmacyrxbsl.com/">canadian pharmacies shipping to usa</a>

meds online

<a href=http://canadianpharmacyrxbsl.com/?propranolol-hydrochloride>propranolol hydrochloride</a>
global pharmacy canada
<a href="http://canadianpharmacyrxbsl.com/?canadian-pharmacy-meds">canadian pharmacy meds</a>

comment:13 Changed 17 months ago by JeffRipt

Cialis Soft Tabs 20mg http://cialtobuy.com - cialis buy online Levitra Que Es Y Para Que Sirve
Levitra Tossicita Viagra Cialis Levitra Combo Packs Direct Worldwide Progesterone Best Website In Canada Cheapeast
Ou Trouver Du Tadalis Sx Soft <a href=http://cialtobuy.com >cialis</a> Cialis J En Ai Pris

Note: See TracTickets for help on using tickets.