Ticket #2046 (new defect)

Opened 11 years ago

Last modified 10 years ago

Toolchain has problems with C++ code...

Reported by: Treviño Owned by: openmoko-devel
Priority: normal Milestone:
Component: host utilities Version:
Severity: normal Keywords: HasPatch
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: yes PatchReviewResult:
Reproducible:

Description

All the times I've tried to compile C++ projects with the Openmoko Toolchain I always got error about missing standard include files (like <new> and so on), so it seems that g++ doesn't look in the right places...

The small workaround I've used to solve the issue is adding the standard include folders as CXXFLAGS and this has always worked with all the projects I've built (mozilla fennec and webkit for example):

--- usr/local/openmoko-light/arm/setup-env	2008-07-29 09:11:34.000000000 +0200
+++ /usr/local/openmoko-light/arm/setup-env	2008-10-01 00:58:12.000000000 +0200
@@ -13,7 +13,7 @@
 export CCLD="ccache arm-angstrom-linux-gnueabi-gcc -march=armv4t -mtune=arm920t"
 export MAKE="make"
 export CFLAGS="-isystem${OMTOOL_DIR}/arm/arm-angstrom-linux-gnueabi/include -fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os"
-export CXXFLAGS="-isystem${OMTOOL_DIR}/arm/arm-angstrom-linux-gnueabi/include -fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os -fpermissive -fvisibility-inlines-hidden"
+export CXXFLAGS="-isystem${OMTOOL_DIR}/arm/arm-angstrom-linux-gnueabi/include -I${OMTOOL_DIR}/arm/arm-angstrom-linux-gnueabi/usr/include/c++/4.1.2 -I${OMTOOL_DIR}/arm/arm-angstrom-linux-gnueabi/usr/include/c++/4.1.2/arm-angstrom-linux-gnueabi -fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os -fpermissive -fvisibility-inlines-hidden"
 export F77="ccache arm-angstrom-linux-gnueabi-g77 -march=armv4t -mtune=arm920t"
 export AS="arm-angstrom-linux-gnueabi-as"
 export AR="arm-angstrom-linux-gnueabi-ar"

Change History

comment:1 Changed 10 years ago by roh

  • HasPatchForReview set

BatchModify?: set HasPatchForReview? on 'keyword' contains 'patch'

Note: See TracTickets for help on using tickets.