Ticket #228 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

openmoko applications(contacts, appmanager ...) easily crash on the phone

Reported by: ken_zhao@… Owned by: mickey@…
Priority: high Milestone:
Component: openmoko-libs Version: current svn head
Severity: blocker Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

contacts:
1.run contacts
2.click menu "Phone Book -> Import" or "Phone Book -> Export"
3.segmentation fault

appmanager:
1.run openmoko-appmanager
2.click menu "openmoko-appmanager -> Install single application"
3.segmentation fault

The issue doesn't occur on PC.
It is really a block for application debug.

Change History

comment:1 Changed 12 years ago by ken_zhao@…

* Bug 216 has been marked as a duplicate of this bug. *

comment:2 Changed 12 years ago by ken_zhao@…

openmoko-stylus-demo on the phone:

1.run openmoko-stylus-demo
2.click first button on toolbox and show a dialog
3.click close button
4.segmentation fault

comment:3 Changed 12 years ago by mickey@…

I need at least a gdb backtrace to even guess about the reason.

comment:4 Changed 12 years ago by ken_zhao@…

gdb openmoko-stylus-demo
demo-main.c line 239

(gdb) n
239 gtk_dialog_run (GTK_DIALOG (dialog));
(gdb) n
(openmoko-stylus-demo:2828): DEBUG: openmoko-stylus-demo: filter changed
to 'Some'
(openmoko-stylus-demo:2828): Gdk-WARNING
: gdk_property_get(): length value
has wrapped in calculation (did you pass G_MAXLONG?)
(openmoko-stylus-demo:2828): GdkPixbuf?-CRITICAL : gdk_pixbuf_new_from_data:
assertion `height > 0' failed
(openmoko-stylus-demo:2828): GdkPixbuf?-CRITICAL
: gdk_pixbuf_scale:
assertion `src != NULL' failed

Program received signal SIGSEGV, Segmentation fault.
0x407bf978 in g_atomic_int_get () from /usr/lib/libglib-2.0.so.0
(gdb)
Single stepping until exit from function g_atomic_int_get,
which has no line number information.

Program terminated with signal SIGSEGV, Segmentation fault.
The program no longer exists.

How to get backtrace infomation? I type "bt" in gdb, but "No stack" is showed.

comment:5 Changed 12 years ago by thomas@…

I have managed to get this backtrace from the contacts crash:

#0 0x4037f0ec in cb_filter_menu_update () from /usr/lib/libmokoui.so.0
#1 0x40ad536c in g_cclosure_marshal_VOIDVOID ()

from /usr/lib/libgobject-2.0.so.0

#2 0x40accc44 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#3 0x40ad7fac in ?? () from /usr/lib/libgobject-2.0.so.0

You need to install the relevent dbg packages on the phone to get the debug
information.

comment:6 Changed 12 years ago by ken_zhao@…

openmoko-stylus-demo backtrace:

(gdb) bt
#0 0x407ca978 in g_atomic_int_get () from /usr/lib/libglib-2.0.so.0
#1 0x4077bae0 in g_object_unref () from /usr/lib/libgobject-2.0.so.0
#2 0x409c7fc4 in ?? () from /usr/lib/gtk-2.0/2.4.0/engines/libpixmap.so
Cannot access memory at address 0x360

comment:7 Changed 12 years ago by ken_zhao@…

openmoko-stylus-demo runs OK while disabling openmoko-standard theme.
Maybe the issue is caused by libpixmap.so.

comment:8 Changed 12 years ago by ken_zhao@…

Disable border setting in gtkbutton, appmanager and openmoko-stylus-demo run
OK.
Contacts still crashes.

comment:9 Changed 12 years ago by mickey@…

We need to find the root of this problem.

comment:10 Changed 12 years ago by aloril@…

Maybe fix to #245 solves this too?

comment:11 Changed 12 years ago by alphaone@…

  • Status changed from new to closed
  • Resolution set to fixed

Okay, these really seem to be various issues.

1) Contacts -> Phone Book -> Im-/Export

This seems related to Bug #268 which got fixed.

2) Appmanager segfault/openmoko-stylus-demo

I wasn't able to reproduce these. Maybe some theme related problems that got

fixed in the meantime?

I'm going to close this bug for now. If anyone still has problems please open a
bug about the specific problem and don't reopen this one.

comment:12 Changed 12 years ago by alphaone@…

Sorry, the contacts problem was related to a Bug that got fixed in Revision 1411
and not to Bug #268.

Note: See TracTickets for help on using tickets.