Ticket #2288 (closed defect: invalid)

Opened 9 years ago

Last modified 9 years ago

xf86-video-glamo: xrandr --output LCD --rotate left fails, xrandr -o 1 works

Reported by: lindi Owned by: openmoko-kernel
Priority: highest Milestone:
Component: kernel Version:
Severity: normal Keywords: xorg xf86-video-glamo xrandr
Cc: lars@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

Steps to reproduce:
1) xrandr -o 1
2) xrandr --output LCD --rotate left

Expected results:
2) screen is rotated
3) screen is rotated

Actual results:
2) screen is rotated
3) the command fails with
xrandr: screen cannot be larger than 480x640 (desired size 640x480)

More info:
1) I'm using xserver-xorg-core package version 2:1.6.1-1 from debian unstable and version 451398a21 of xf86-video-glamo from 2009-03-02

2) This has been discussed as a debian bug at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=529078

Change History

comment:1 Changed 9 years ago by nicolas.dufresne

I've got the same on my laptop with Radeon 7500, so I guess this is generic Xorg issue. It turns out that this issue is related to the way the virtual screen are handled in Xorg. If you want to change something only on one output, you need your change to fit into the Screen current virtual size. When you don't specify the output, it looks like the change is done at a higher level where the virtual can be updated. I suggest trying this Xorg configuration to get the command 2 to work. Note that command 1 and 2 are no equivalent. Also, command 2 is generally use in the context of multi-head operation.

Section "Screen"

Identifier "Screen0"
Device "Videocard0"
DefaultDepth? 16
SubSection? "Display"

Viewport 0 0
Depth 16
Virtual 640 640

EndSubSection?

EndSection?

comment:2 Changed 9 years ago by lars

  • Status changed from new to closed
  • Priority changed from normal to highest
  • Resolution set to invalid

closing as invalid since it's not a bug in the glamo driver.

Note: See TracTickets for help on using tickets.