Ticket #253 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

Typo in /etc/init.d/checkroot.sh prohibits correct processing /etc/fstab

Reported by: oe@… Owned by: mickey@…
Priority: high Milestone:
Component: OE bitbake recipes / build system Version: unspecified
Severity: blocker Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Currently /tmp is not mounted as tmpfs which means all writes into /tmp cause
flash-wear.

Attachments

base-files.patch (348 bytes) - added by oe@… 12 years ago.
Patch against packages/base-files

Change History

Changed 12 years ago by oe@…

Patch against packages/base-files

comment:1 Changed 12 years ago by philippedeswert@…

  • blocked set to 144

This probably also removes the need for the hack in #144. As /tmp will be
tmpfs, the contents of /tmp will be gone when the device reboots. No need to
clean /tmp.

comment:2 Changed 12 years ago by mickey@…

  • Severity changed from normal to blocker
  • Summary changed from Mount /tmp as tmpfs to Typo in /etc/init.d/checkroot.sh prohibits correct processing /etc/fstab

/tmp is actually a link to /var/tmp which is supposed to be mounted as a tmpfs
-- at least according to /etc/fstab. Now the problem is something different
(which is why I'm changing the title of this bug): During boot, checkroot.sh emits:

sh: rw: unknown operand

I traced the offending line down to:

if [ $(grep "$ROOTFSDEV\w" /proc/mounts | awk '{print $4}') = "rw" ]; then

comment:3 Changed 12 years ago by jluebbe@…

  • Status changed from new to closed
  • Resolution set to fixed

Mickey has fixed this bug by using 'mount -a' instead of 'mount -at no...',
because busybox mount does not support -t no...

A bug has been filed agains busybox in OE-Bugzilla.

Note: See TracTickets for help on using tickets.