Ticket #264 (closed defect: fixed)

Opened 12 years ago

Last modified 21 months ago

package libelf-0.8.6-r0: task do_populate_staging: failed

Reported by: denis.kot@… Owned by: mickey@…
Priority: high Milestone:
Component: Applications & Dependencies Version: current svn head
Severity: normal Keywords:
Cc: buglog@…, vyzivus@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

localhost moko # make clean-package-libelf
( source ./setup-env ; cd build ; bitbake -c clean libelf )
NOTE: Using cache in '/home/moko/build/tmp/cache/x86'
NOTE: Handling BitBake? files: | (4321/4321) [100 %]
NOTE: Parsing finished. 4131 cached, 0 parsed, 190 skipped, 0 masked.

NOTE: build 200703131409: started

OE Build Configuration:
BB_VERSION = "1.6.7"
OE_REVISION = "<unknown>"
TARGET_ARCH = "i486"
TARGET_OS = "linux"
MACHINE = "x86"
DISTRO = "openmoko"
DISTRO_VERSION = ".dev-snapshot-20070313"
TARGET_FPU = ""

NOTE: package libelf-0.8.6: started
NOTE: package libelf-0.8.6-r0: task do_clean: started
NOTE: removing /home/moko/build/tmp/work/i486-linux/libelf-0.8.6-r0
NOTE: removing /home/moko/build/tmp/stamps/i486-linux/libelf-0.8.6-r0.*
NOTE: package libelf-0.8.6-r0: task do_clean: completed
NOTE: package libelf-0.8.6: completed
NOTE: build 200703131409: completed
Build statistics:

Attempted builds: 1

localhost moko # make all
( cd build ; . ../setup-env ; \

bitbake openmoko-devel-image )

NOTE: Using cache in '/home/moko/build/tmp/cache/x86'
NOTE: Handling BitBake? files: | (4321/4321) [100 %]
NOTE: Parsing finished. 4131 cached, 0 parsed, 190 skipped, 0 masked.

NOTE: build 200703131410: started

OE Build Configuration:
BB_VERSION = "1.6.7"
OE_REVISION = "<unknown>"
TARGET_ARCH = "i486"
TARGET_OS = "linux"
MACHINE = "x86"
DISTRO = "openmoko"
DISTRO_VERSION = ".dev-snapshot-20070313"
TARGET_FPU = ""

NOTE: preferred version 2.12.3 of glib-2.0 not available
NOTE: preferred version 1.0.2 of dbus-native not available
NOTE: multiple providers are available (db3-native, db-native);
NOTE: consider defining PREFERRED_PROVIDER_virtual/db-native
NOTE: multiple providers are available (db3, db);
NOTE: consider defining PREFERRED_PROVIDER_virtual/db
NOTE: package libelf-0.8.6: started
NOTE: package libelf-0.8.6-r0: task do_fetch: started
NOTE: package libelf-0.8.6-r0: task do_fetch: completed
NOTE: package libelf-0.8.6-r0: task do_unpack: started
NOTE: Unpacking /home/moko/sources/libelf-0.8.6.tar.gz to
/home/moko/build/tmp/work/i486-linux/libelf-0.8.6-r0/
NOTE: Unpacking /home/moko/sources/libelf-0.8.6.tar.gz to
/home/moko/build/tmp/work/i486-linux/libelf-0.8.6-r0/
NOTE: package libelf-0.8.6-r0: task do_unpack: completed
NOTE: package libelf-0.8.6-r0: task do_patch: started
NOTE: package libelf-0.8.6-r0: task do_patch: completed
NOTE: package libelf-0.8.6-r0: task do_configure: started
NOTE: package libelf-0.8.6-r0: task do_configure: completed
NOTE: package libelf-0.8.6-r0: task do_compile: started
NOTE: package libelf-0.8.6-r0: task do_compile: completed
NOTE: package libelf-0.8.6-r0: task do_install: started
NOTE: package libelf-0.8.6-r0: task do_install: completed
NOTE: package libelf-0.8.6-r0: task do_package: started
NOTE: package libelf-0.8.6-r0: task do_package: completed
NOTE: package libelf-0.8.6-r0: task do_package_write: started
NOTE: Not creating empty archive for libelf-dbg-0.8.6-r0
NOTE: Not creating empty archive for libelf-0.8.6-r0
NOTE: Not creating empty archive for libelf-doc-0.8.6-r0
Packaged contents of libelf-dev into
/home/moko/build/tmp/deploy/ipk/i486/libelf-dev_0.8.6-r0_i486.ipk
Packaged contents of libelf-locale-de into
/home/moko/build/tmp/deploy/ipk/i486/libelf-locale-de_0.8.6-r0_i486.ipk
NOTE: package libelf-0.8.6-r0: task do_package_write: completed
NOTE: package libelf-0.8.6-r0: task do_populate_staging: started
ERROR: function do_stage failed
ERROR: log data follows
(/home/moko/build/tmp/work/i486-linux/libelf-0.8.6-r0/temp/log.do_stage.29387)
| oe_libinstall: cd lib
| oe_libinstall: install -d /home/moko/build/tmp/staging/i486-linux/lib
| oe_libinstall: install -m 0644 libelf.a
/home/moko/build/tmp/staging/i486-linux/lib

| FATAL: oe_libinstall: unable to locate shared library
NOTE: Task failed:
/home/moko/build/tmp/work/i486-linux/libelf-0.8.6-r0/temp/log.do_stage.29387
NOTE: package libelf-0.8.6-r0: task do_populate_staging: failed
ERROR: TaskFailed? event exception, aborting
NOTE: package libelf-0.8.6: failed
ERROR: Build of openmoko-devel-image failed
make: * [openmoko-devel-image] Error 1

Change History

comment:1 Changed 12 years ago by abraxa@…

I ran into the same problem and fixed it by manually running "./configure --enable-shared" in the libelf
dir, followed by a make. Then the shared lib was ready for installation so the MokoMakefile? continued
without problems.

Platform: Gentoo 32bit x86

comment:2 Changed 12 years ago by denis.kot@…

  • Status changed from new to closed
  • Resolution set to fixed

thanks! I helps!
same dist and arch.

comment:3 Changed 12 years ago by freyther@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

Well, manually toying in the workdir is obviously not a fix.

I have seen this bug at least three times on Moko irc. It has to do with TARGET_ARCH set to i486 and libelf
claiming i486 can't have shared libraries. You have either the option to fix libelf's autoconf abuse or to
bump TARGET_ARCH to i686. TARGET_ARCH gets set to i486 by the x86.conf inside the oe/conf/machine
directory of openmoko.

comment:4 Changed 12 years ago by koen@…

This has been fixed in OE .dev last week

comment:6 Changed 12 years ago by alphaone@…

Is this still an issue? Dennis, please close this bug if the package builds for you.
Thanks

comment:7 Changed 12 years ago by denis.kot@…

  • Status changed from reopened to closed
  • Resolution set to fixed

closed

comment:8 Changed 12 years ago by abraxa@…

  • Cc vyzivus@… added

comment:9 Changed 12 years ago by abraxa@…

* Bug 526 has been marked as a duplicate of this bug. *

comment:10 Changed 12 years ago by openmoko@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

I run into this problem, so it does not seem to be resolved. :-( Or someone
forget to commit something? I can manualy ./configure for this package but I can
also wait a while and verify it after someone fix it.

My configuration:
MACHINE = "qemux86"
DISTRO = "openmoko"
BUILD_ARCH = "i686"
INHERIT+=" devshell"
SRCDATE_eds-dbus="now"

comment:11 Changed 12 years ago by openmoko@…

  • Status changed from reopened to closed
  • Resolution set to fixed

sorry for reopening this bug... the problem was with frozen revision of
openembeded when using Mokomakefile. Rod Whitby just commited the patch (thanks
again).

comment:12 Changed 2 years ago by Chassmetly

Levitra Orodispersible Rezeptfrei <a href=http://cial5mg.xyz>Buy Cialis</a> Par 701 Clomid For Sale Prednisone Without A Scrip <a href=http://viag1.xyz/generic-viagra-sales.php>Generic Viagra Sales</a> Viagra Fa Bene Colchicine Tablet 0.6 Mg <a href=http://kama1.xyz/order-kamagra-tablets.php>Order Kamagra Tablets</a> Viagra Ohne Rezept Online Kaufen Does Amoxicillin Cause Increased Thirst <a href=http://clomid.ccrpdc.com/fast-delivery-clomid.php>Fast Delivery Clomid</a> Finasteride Acne Where Can I Get Cyprohepadine <a href=http://kama1.xyz/buy-kamagra-gel.php>Buy Kamagra Gel</a> Sun Exposure And Amoxicillin Cialis Prix 5mg <a href=http://viag1.xyz/cheapest-viagra-online.php>Cheapest Viagra Online</a> Order Viagra Achat Kamagra Naturel <a href=http://kama1.xyz/kamagra-online-fast.php>Kamagra Online Fast</a> Cialis In Hamburg

comment:13 Changed 21 months ago by HaroNusy

Real Pfiefer Viagra http://cialtobuy.com - online pharmacy Canada Companys That Sell Cialis
Dutasteride Order Now Store Cialis En Ligne Costo Cialis O Viagra
Levitra Billig <a href=http://cialtobuy.com >cialis</a> Propecia Minoxidil Before

comment:14 Changed 21 months ago by HaroNusy

Active Ingredient Propecia http://cialtobuy.com - cheap cialis Zithromax At Walmart
Online Medications Precio Cialis 10 Mg Lilly
Cialis Online Paypal <a href=http://cialtobuy.com >cialis</a> Priligy Dapoxetine Side Effects

Note: See TracTickets for help on using tickets.